SSL let's encrypted

Hello could you help please to understand what problem with www.s.apv.one - it’s not opening. I have let’s encrypted SSL on www.s.apv.one but it’s not working.

I use Full mode in SSL in Cloudflare.

The www is a second-level subdomain. The Cloudflare Universal SSL certificate only covers apv.one and *.apv.one. You will need to use the Advanced Certificate to cover this hostname.

Use only “Full (strict)” to ensure your origin SSL certificate is validated.

Thank you. But if I switch to Full (Strict) the site doesn’t work.
Do you know why?

Can I use my own Let’s encrypted SSL certificate instead of Cloudflare?

If you have a Business or Enterprise plan, then you can upload your own certificate…

May be:

  • The Universal SSL certificate issue as already mentioned
  • Your origin SSL certificate isn’t valid or installed correctly

Pause Cloudflare, or set the DNS record to “DNS only”, and check the site works directly to the origin first. Then you can re-enable the proxy.

1 Like

Thanks a lot! Your suggestions helped.

The problem was with SSL. A regenerated SSL and changed mode to Full (strict) and now all are working good. and www.s.apv.one too.

This one won’t work with the proxy unless you use the Advanced Certificate.
https://cf.sjr.org.uk/tools/check?1bc5a2873e604e469d191a670fca703e#connection-server-https
https://cf.sjr.org.uk/tools/check?4aebf54d47b24edf81d8209a159d6ef0#connection-server-https

Yes, you are right. I just setup a redirect from www.s.apv.one to s.apv.one by page rule.
It’s enough)

Thank a lot!

That still won’t work when proxied, since http://www.s.apv.one redirects to https (or if going to https directly), so it still needs the SSL certificate for www.s.apv.one before the browser can reach Cloudflare to be redirected.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.