SSL just failed

dash-crypto
#1

Greetings all!
I’ve been running 8 domains through CF for a while now and have become comfortable enough with platform stability and function that I moved my primary domain here~6-7 months ago.

I noticed this morn that when I open my primary site, it’s no longer https://www , it’s just the domain name now.

Cert on the host is good through the end of this month. It just quit working this morn and it’s got me baffled. I CAN manually type in the full ssl URL and that works. Setting is on “full (strict)”.

It’s been working fine for months and for ‘seemingly’ no reason, it just stopped this morn.

Any thoughts?

#2

It’s not a change in your browser, is it? Some browsers hide all the leading stuff, such as the scheme and the ‘www’.

Try a different browser to see if it displays the URL differently.

Or post the domain so we can take a look as well.

p.s. And just to be sure, make sure in your Crypto settings you’ve enabled “Always Use HTTPS” and “Automatic HTTPS Rewrites”.

#3

Thanks for the quick input sdayman!
Crypto settings are correct and I’ve tested in Firefox 66.0.5 (64-bit) and Chrome. Same in either, this from my primary machine here, but same on the server here (Ubuntu server with firefox).

It’s been working flawlessly for months.

Domain is stevespages.com

#4

Entering www.domain.com works, however domain.com does not show secure and does not redirect. This is probably because that record is set to :grey:, whereas www is set to :orange:.

2 Likes
#5

domjh, This is not something I had noticed but you’re 100% right.

There was an A record pointing to the host server that I enabled.
Hopefully, that will resolve this.

Many thanks! I’ll watch this for a day or two and comment back to this thread!

Cheers!

1 Like
#6

Hopefully this will fix the issue, yes please do let us know if it works! No problem :slightly_smiling_face: