SSL issues on subdomains when activating Cloudflare


I get ‘ERR_SSL_UNRECOGNIZED_NAME_ALERT’ on all my subdomains (, and when I activate Cloudflare.

I have tried disabling Cloudflare and re-enabling after 24 hours. I have tried changing the SSL settings and using ‘Strict’, ‘Strict (Full)’ and ‘Flexible’ - none of these options work. I’ve also tried disabling universal SSL and then re-enabling it. Nothing seems to work.

I have read the instructions on this ticket but I don’t know how to submit PATCH requests and there isn’t really any instructional information to show you how to in this article…Community Tip - Fixing ERR SSL VERSION OR CIPHER MISMATCH in Google Chrome

For now, I have had to disable Cloudflare all together to get my subdomains working.

Current settings on Cloudflare:

  • Cloudflare temporarily paused
  • SSL/TLS encryption mode: Full (strict)
  • Edge certificate: Universal (active)
  • Always use HTTPS: Off
  • HSTS: Disabled

All other settings are set to the default, standard settings.

Please help!

Thanks, Stephen

Subdomain too deep has more on that.

As for the encryption mode, that’s unrelated to the issue and it should be Full Strict, otherwise it is not secure.

So, just to be clear, to solve the issue I just need to set the ‘www.subdomain’ A record to ‘DNS only’ and then it should be fine?

Yes, either you unproxy the record or you get an ACM certificate.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.