SSL Issues on my webpage

Well i recently got a free ssl certificate from Cloudflare for my site (advanteachvr.com) but it is not working, everytime i try to access via https i get this : ERR_SSL_PROTOCOL_ERROR or ERR_CONNECTION_REFUSED.

I´m hosting my web on a raspberry pi and i’m using wordpress, and i installed really simple ssl, and it says : “Detected possible certificate issues
Really Simple SSL failed to detect a valid SSL certificate”.

On Cloudflare it says active certificate, and ssl report from ssllabs shows grade “A”.

Any help is appreciated,

Thanks

PS:English is not my native language.

Site loads and looks OK for me in sunny Australia.

Hi saul, yes it works but without https. If you try https://advanteachvr.com you will see what im saying.

Thanks.

image

Works for me. What browser and OS are you using?

2 Likes

All works for me mate :+1:

Flush your DNS cache etc., you could still be seeing a hangover of prior testing and use.

1 Like

I´m using chrome (Versión 70.0.3538.67 (Build oficial) (64 bits)) and Win10 and i tried with Microsoft Edge too,but i keep getting the same error i don’t understand…

Now i tried to access from a diferent network and it works. The problem seems to be using my home network but i don’t know why.

Thanks guys for your responses.

1 Like

Maybe you’re accessing it using your internal IP so hitting the local SSL cert and that isn’t quite right, whereas we’re hittng the Cloudflare IP with their good cert and SSL config.

If your crypto mode is ‘flexible’, say, Cloudflare may be connecting to you without SSL but serving viewers outside network with SSL, hence the difference in what we see.

1 Like

Loads fine for me and also at http://sitemeer.com/#https://advanteachvr.com/

That would suggest you are bypassing Cloudflare. Can you ping your domain and post the output here?

Ok guys, i did the ping test.

ping “advanteachvr.com” goes to my home ip
ping “www.advanteachvr.com” goes to Cloudflare ip

i changed my wordpress page url from advanteach to www.advanteach and it works, just a few images dissapeared.

Now the question is why i need to add “www” ?
And if it’s possible to reduce the load time?

Thanks again for your help :smiley:

You most likely have an entry for your domain in your hosts file.

This topic was automatically closed after 30 days. New replies are no longer allowed.