SSL Issues on Host provider and Cloudflare

Hello
I am trying to upgrade my hosting plan but there is an issue with my SSL settings. My hosting says it will not be possible to set the SSL for the domain in the new plan because my domain is at Cloudflare and the nameservers are not the ones of Godaddy. So, they say that in order to be able to set their SSL I should change the nameservers or it won’t’ be possible to enable it. Can you please give me an alternative? I would like to change the plan but am not at the disposition of leaving Cloudflare or disconnecting from Cloudflare. Is there any option to enable the SSL without doing what they ask me? My SSL is from GoDaddy and should set up automatically since they come with the plan.
Thanks

Since you’re using Cloudflare, you can install a Cloudflare Origin SSL certificate of your own. There are instructions here (farther down) for doing it on GoDaddy.

Hi
Unfortunately, using that SSL is not an option because the plan I am trying yo upgrade to, pro 5 managed wordpress, does not allow third party SSL. I did pause Cloudlare on the site and t returned to te previous plan and the SSL got enabled again . What I am going to do is change again the IP address on DNS settings, with Cloudflare paused for the site and enable it only after the site in the new plan is resolving and with the SSL enabled. Idid read some of the answers on the forum about some other hostings , more friendly with Cloudflare but the thing is, I did consider moving to Dreamhost, that seems to be a great host, but their more suitable plan for my sites (the top one) on dreampress only allows one site and I have 2, what would make it too expensive considering that my sites are a hobby. When we have sites with high traffic, (200 unique visitors at same time or more many times a day) it is not easy to get an affordable hosting. that’s why i need to see if I can make this top plan at Godaddy to work.

So, please if you have some tips to help me on this, they will be much appreciated. After tis one is working on the new plan, I will have the other too, to move.

Thanks

Hello I am still waiting for my hosting - godaddy- to enable the SSL on my site.Since I have been waiting for 48 hours, contacted the support and they told me yesterday that the reason why the SSl is not enbled yet was because I didn have a CAA record on my hosting account set with «issue» and «godaddy-.com» as value. So, last night I went to the DNS hosted on my Godaddy account (didn’t make any changes on DNS of Cloudflare where my site is registered) and I am waiting it to propagate to see if finally the SSL gets enabled. But I would like to clarify if I need to add any CAA record too here on Cloudflare DNS settings and also if the CAA that I did add on hosting account conflicts in any way with the universal SSL of Cloudflare. Right now I still have the Cloudflare paused, waiting to have the SSL enabled on hosting. Thanks

You need to add that CAA record to which ever DNS is authoritative for your domain. Since you say you have Cloudflare paused, that implies you’re still using Cloudflare’s name servers. So add it here as well.

Ok thanks for the answer. II am trying to get some update from hosting, about the SSL that keeps without getting enabled. Meanwhile i am going to create the record on my DNS at Cloudflare and will reply when I have this solved.

1 Like

This is the final update for the issue I did report on the topic. I want to say that it was not caused by Cloudflare , it was a hosting tech problem and is now solved. Thanks

1 Like

mfatimajesus please can yo elaborate what the issue was with your hosting as I am having the same issue where visitors are unable to reach my site and I thought it was an SSL cloudflare problem but now I think it might be linked with the hosting but cannot pin point what?

I think you’re solution is correct!

Hi
I guess I am disappointing you with the solution but here it is: it seems that Godaddy’s SSL keeps asking to verify the site ownership although we set a CAA record pointing to Godaddy CA (certificate authority) both in hosting account and on DNS registrar. And this they are not able to solve. I was on ultimate managed WordPress at Godaddy and decided to upgrade to their top plan: Pro 5 . And even when I did cancel this new plan, after 4 days with the site offline and decided to return to ultimate, it was only yesterday, after more than 24 h that they could set the SSL on the old plan again. I think that one of the problems has to do with the fact that their system sees the site I was rebuilding in the new account as an alias and not the main domain. Go figure because this site is alone on an ultimate managed wp plan.

So, in order to be able to move my sites to the new plan, without having this hassle, I have to transfer the domains to them again, otherwise, they can’t verify the domain and, for that reason, I can’t have the SSL set. And on managed wp we can’t have third party SSL set,

That’s it.

Regards

Thank you for your reply and this sounds v frustrating. My website is not hosted with Godaddy but rather through Github. It’s interested what you mentioned about the host thinking your site was an alias and not the main domain. Maybe this is the same for me.

So in the end did you manage to have SSL set for your sites or did you have to go without?

Hi
Right now the site (I only did try to move one and, after the issues didn’t try to move the other) is showing the correct SSL yes. But it is in the old plan again. I did request the transfer of the domains to GoDaddy again, in order to try the new plan when the domains will be there because they told me that won’t b necessary to verify the sites. And, in my experience, the SSL will be set in a few time. But this shouldn’t happen, I agree with you because it is the same to stell you that, in order to have an SSL working, you must have your domain with them. But I didn’t find a better option for the sites, at least right now.

1 Like