SSL issues https and http issues


my website is I pay $5 to cloudflare per month for SSL and also generated a SSL from cloudflare for origin server which is hosted with webfaction

I have set in cloudflare SSL to Full(Strict) as i want all traffic to be https and not http.

issue i have is if i visit I get the webfaction site not configured but it works, doesnt load the sub directory comes up with the not secure in the address and the webfaction not configured.

and if i load url seems as though not all CSS is been loaded

Your Webserver does not know where to find content to be loaded via http. Check your config, or redirect request with a Page Rule:* 
Forwarding URL - Status 301

Is redirected to HTTP, see above :point_up:

Also enable ‘Always use HTTPS’ and ‘Automatic HTTPS rewrites’ on your Cloudflare dashboard.

Seems to be an issue on your host. HTTP 500

**Response Headers:**

status: 500
expect-ct: max-age=604800, report-uri=""
set-cookie: __cfduid=d5f08695a490175b96d7739bee3be9f161576003292; expires=Thu, 09-Jan-20 18:41:32 GMT; path=/;; HttpOnly
set-cookie: PHPSESSID=a9558d2575cd014fcc2b1359f0ded225; path=/
cf-cache-status: DYNAMIC
expires: Thu, 19 Nov 1981 08:52:00 GMT
server: cloudflare
pragma: no-cache
cache-control: no-store, no-cache, must-revalidate
date: Tue, 10 Dec 2019 18:41:32 GMT
cf-ray: 54315a812dc4cd93-CDG
content-type: text/html; charset=UTF-8
:status: 500

Thanks, didn’t add any page rules but did enable ‘Always use HTTPS’ and ‘Automatic HTTPS rewrites’ on your Cloudflare dashboard under the Edge Certificate. that solved the first 2 issues.

Assume then I should take up the issue with: up with webfaction.

Thank you

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.