SSL issue with Webmin/Virtualmin

Current SSL certificate details
SSL certificate file /home/server/ssl.cert
SSL private key file /home/server/ssl.key
Web server hostname CloudFlare Origin Certificate Organization "CloudFlare
Issuer organization "CloudFlare Expiry date Nov 21 01:48:00 2036 GMT
Certificate type Self-signed
Other domain names *.wftstore.com, server.wftstore.com, wftstore.com, www.server.wftstore.com, www.wftstore.com.
Used by services Webmin (server.wftstore.com), Usermin (host server.wftstore.com), Dovecot (host server.wftstore.com), Postfix (host server.wftstore.com)
Download certificate PEM/PKCS12

Download private key PEM/PKCS12

Time until expiry 5474 days until expiry

WordPress website is UP with SSL installed. No problem there. Only with Webmin.


SSL works perfectly on the Website. However, it doesn’t work on Webmin. Am I doing something wrong?

I’m trying to install Cloudflare Origin SSL for the Webmin panel. Self-encrypt works perfectly on Webmin.
Also, when I enable “Cloudflare proxy” for Webmin (in order to activate SSL), the server stops working and I cannot log in.

May I ask what error do you get?

Over which port is Webmin running so far?

Have you checked at Webmin forums?:

Some other similar topics with useful information about Webmin :search: :

While using Cloudflare Origin CA Certificate, may I ask are you also having the Full (Strict) SSL selected under the SSL/TLS tab of Cloudflare dashboard for your domain name?

Furthermore, kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Ports list compatible and supported when using :orange: cloud (proxy mode) on Cloudflare can be found here:

1 Like

Q: May I ask what error do you get?
A: SSL mismatch when using server.domain.com (Webmin panel)

Q: Over which port is Webmin running so far?
A: 10000 - default

Q: While using Cloudflare Origin CA Certificate, may I ask are you also having the Full (Strict) SSL selected under the SSL/TLS tab of Cloudflare dashboard for your domain name?
A: Yes

Without Cloudflare Proxy - Enabled I get a mismatch error.
When I enable Proxy I can’t access the server at all.
EDIT:
I just noticed that without PORT(:10000) it loads and SSL is active. However, with port, I can’t access the server.
How can I fix this issue?

Thank you.

Have you tried using some other Web browser while testing?

Use Origin Certificate Authority (CA) certificates to encrypt traffic between Cloudflare and your origin web server and reduce origin bandwidth consumption. Once deployed, these certificates are compatible with Strict SSL mode.

You cannot use Cloudflare Origin CA Certificate with :grey: (DNS-only). It throws warnings to the end-user/visitor:

Site visitors may see untrusted certificate errors if you pause or disable Cloudflare on subdomains that use Origin CA certificates. These certificates only encrypt traffic between Cloudflare and your origin server, not traffic from client browsers to your origin.

Right, here the issue if using :orange: (proxied) mode.

You might have to change the port to some other - compatbile & supported by Cloudflare proxy :orange: mode:

1 Like

Problem resolved. I just had to use CF-compatible ports and whitelist them.

Thank you very much!
Hvala i živ bio!

1 Like

Awesome! :+1: I am happy to assist you :slight_smile:

Odlično! :wink:
Drago mi je da sam uspio barme malo pomoći :slight_smile:
p.s. Sljedeći se puta “na našem” brže i lakše sporazumijemo samo me taggaš :slight_smile:

Svako dobro!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.