SSL Issue - Not forcing to https:// website

For the past few hours I am facing some kind of interesting problem. On my site https://shadnanm.com/ some of the pages are loading without https://. And later they are showing me “no padlock” on the browser. When I refreshed the page then it’s showing the https://.

After few minutes later when I tried again it’s again http:// and after a normal refresh it’s https:// again. I enabled force https:// option on both cloudflare and on my hosting from the very first time (an year ago) and I never faced this kind of issue earlier.

Checked with my other browsers and it was same for the other browsers too.

Is it any kind of cloudflare issue? Because I didn’t do any changes for the last two days on my site.

Do you mean you already enabled this option?

Not sure whether this is caused by the Mixed Content issue. Next time when you see the Not Secure warning, click that button and see whether it says “Your connection to this site is not fully secure” instead of “Your connection to this site is not secure”.

1 Like

Hi @erictung

Yes enabled this option an year ago. Checked this few min ago and it was on.

1 Like

Thanks for the reply. BTW, I checked mixed content issue with WP plugin and no issues at all. Interesting thing is it become normal with just a normal refresh.

Confirmed that your first visit is in HTTP instead of HTTPS?

Can you post the URL of a page that didn’t load HTTPS on the first try?

I tried both HTTP & HTTPS. HTTPS is simply okay. For HTTP sometimes it opens with “no padlock” and sometimes it forces https://

Almost every pages except the homepage. You can check -


The funny thing is I told to check one of my client who is in USA she confirmed that everything is okay on her side. And one of my friend (from my country) confirmed he is also getting the same error. Funny :wink:

@sdayman @erictung

Check this. It’s on normal load
Issue
And after a simple refresh
Issue 2

On my cloudflare “Always Use HTTPS” is enabled and on my .htaccess I set force HTTPS as well.

Same here. I can not replicate the issue.

2 Likes

Not sure whether this is browser-related issue. Can you clear your browser cache and cookies and try again?

1 Like

Me too. I can’t replicate the issue.

1 Like

Thanks @erictung @sdayman

The issue is solved now. Didn’t do anything. Solved automatically. :grinning:

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.