SSL Issue GoDaddy https Appears Future home of something quite cool. If you're the site owner, log in to launch this site If you are a visitor, check back soon

ssl
https
godaddy

#1

Hi There,

I have a website (Wordpress) which needed SSL certificate. I went through the process and installed SSL.

When I go to the website martennis.net it appears:
‘Future home of something quite cool. If you’re the site owner, log in to launch this site. If you are a visitor, check back soon.’

I thought perhaps I did something wrong so I went through the process again.

Cloudflare is saying that it is active.

Can someone guide me through this? Have I missed a step?


#2

Did your site work with HTTPS before you added it to Cloudflare?

Which SSL setting are you using? Is it Flexible or Full (check your Cloudflare Crypto settings page). It should probably be Flexible.


#3

Hi,

It was the Free SSL. The website was only http before and I followed the instructions for adding it to Cloudflare. It is Full and was flexible but changed it thinking that might solve the problem. But still nothing.
Any ideas?

Thanks for the speedy reply
Mark


#4

For now, can you go to your Cloudflare DNS settings and set martennis.net and www to :grey:? I’d like to see how your server responds to HTTP as well as HTTPS.


#5

Hi there,

It isn’t currently? I thought I added the DNS into GoDaddy.


#6

You’re using Cloudflare DNS, and you have it set to :orange: so the site is served through Cloudflare. And HTTPS doesn’t work.

What usually happens is that sites which don’t support HTTPS work fine on HTTP, but when you try HTTPS, they redirect you to a Parked Domain page.


#7

I can do it again, if its not setup.


#8

Ah yes this is what I see must be happening. What do you suggest to solve it?


#9

Set them to :grey: so we can troubleshoot.


#10

Hi There,

Followed your instructions all cloud symbols are gray. Whats the next step?

Thanks
Mark


#11

There’s no valid SSL certificate there. I’m pretty sure you need Cloudflare’s SSL set to Flexible.
And for Flexible, I recommend this Wordpress Plugin:


#12

I have CloudFlare Flexible SSL.

I have now changed Cloudflare from Full to flexible.

What else to I do? I attached screenshot of DNS panel.


#13


This is my current setting with the DNS. Is this correct? They are all gray and not green.

I followed other steps Full to flexible.

What else do I need to do?


#14

Now set martinis.net and www to :orange:


#15

Hi THere,

Can you instruct me on the exact process please? Did you see the screenshot?

Thanks
Mark


#16

In that DNS page, click on the grey cloud so it turns orange. Just do it for the (looking out for spellcheck) “martennis.net” and “www” entries.


#17

Done. When I type https://www.martennis.net it works. However is the website secure? Does this mean I have an SSL certificate? Can you explain this? The reason I’ve added SSL certificate if because google was red flagging the website.


#18

Hi There,

Done. It says the When I type https://www.martennis.net it works. However is the website secure? After clicking on the ‘I’ information button, Has a warning: Your connection to this site is not fully secure. Does this mean I have a bad SSL certificate? Can you explain this? How do I get fully secure?


#19

You’re super close! In your Cloudflare Crypto settings page, have you turned on “Automatic HTTPS rewrites”?


#20

Done. And then?