SSl is valid but still Site not secure

Hello Everyone, I have created a website and uploaded a valid certificate on origin server and also setup cloudflare on full but still my site is not showing up a lock sign I have also checked for mixed content but thats not the issue when I set up cloudflare to full (strict) it throws 526 error.
kindly suggest me how can I get a lock sign on my site on both full and full(strict) mode.
My domain is:

Is your site currently configured as Full (Strict)? It’s now working (except for mixed content) for me.

Just as additional help…
Error 526 indicates Cloudflare is unable to successfully validate the SSL certificate on the origin web server. Make sure you have configured a valid certificate on your server. See this 526 Community Tip for suggestions.

Go to SSL/TLS > Edge Certificates page and enable Automatic HTTPS Rewrites option. There is a mixed content issue with your website.

Thanks for your reply i have already set automatic https rewrites but still not worked.
then i have manually fixed these mixed content and now the site is showing lock icon

I have a valid certificate on my server but still getting error 526 when set to full strict mode now full mode is working fine. Thank you.

@matteo’s link is spot on.

If you have a valid certificate you won’t get a 526. If you get a 526 you won’t have a valid certificate.

You better double check everything, from your DNS records to your server configuration and certificates. With Full you technically still have encryption, however without validation, hence the site is as “secure” as with any self-signed certificate.

1 Like

Actually my certificate is valid but i just figured out that problem is that there is no ca bundle uploaded on my origin server and that is because I am on free byethost hosting which does not allow to upload ca bundle on its free hosting.
So, I think I have to upgrade my hosting plan if I want to use full (strict) mode.
Thank you.

This topic was automatically closed after 30 days. New replies are no longer allowed.