SSL is off, but it will still force a jump to HTTPS

The domain name I use is smart-treatment.club, and the domain name provider is GoDaddy. I have set nameserver, which is already activated. However, if I set a record WWW, accessing HTTP will force a jump to HTTPS, and 404 will be displayed. I have not set SSL to open. If I set a record www1, it is normal. I am very sorry. I am using translation communication. Thank you for your reply

MacBook-Pro:~ wp$ curl http://www.smart-treasure.club -v 
*   Trying 104.21.93.158...
* TCP_NODELAY set
* Connected to www.smart-treasure.club (104.21.93.158) port 80 (#0)
> GET / HTTP/1.1
> Host: www.smart-treasure.club
> User-Agent: curl/7.64.1
> Accept: */*
> 
< HTTP/1.1 301 Moved Permanently
< Date: Sat, 25 Sep 2021 03:17:23 GMT
< Content-Type: text/html
< Transfer-Encoding: chunked
< Connection: keep-alive
< Location: https://www.smart-treasure.club/
< CF-Ray: 69411962cd91eb1d-LAX
< CF-Cache-Status: DYNAMIC
< Set-Cookie: __cfruid=a066cbe508def91c309ba0ba4eb328f4b7c7ea76-1632539843; path=/; domain=.www.smart-treasure.club; HttpOnly
< Server: cloudflare
< alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400
< 
<html>
<head><title>301 Moved Permanently</title></head>
<body>
<center><h1>301 Moved Permanently</h1></center>
<hr><center>openresty</center>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"69411962cd91eb1d","token":"4899d52b0163417188dd0aea7e743a2e","version":"2021.8.1","si":10}'></script>
</body>
</html>
* Connection #0 to host www.smart-treasure.club left intact
* Closing connection 0
MacBook-Pro:~ wp$ curl http://www1.smart-treasure.club -v 
*   Trying 104.21.93.158...
* TCP_NODELAY set
* Connected to www1.smart-treasure.club (104.21.93.158) port 80 (#0)
> GET / HTTP/1.1
> Host: www1.smart-treasure.club
> User-Agent: curl/7.64.1
> Accept: */*
> 
< HTTP/1.1 200 OK
< Date: Sat, 25 Sep 2021 03:25:24 GMT
< Content-Type: text/html
< Transfer-Encoding: chunked
< Connection: keep-alive
< CF-Cache-Status: DYNAMIC
< Report-To: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=UhwMOEqN5m92hUIW4pOnv40WGGD5RX25MiCldDUQUHreQR8RB4s0qtnQzfqn%2FgboaggdfI%2BnnF3LMeYI%2FI3jBTf0Qr9aIuEnosO5LpOOuKwCAYPQqPT78wd6xl9qBKzV1OPxWoO9DO%2F1Az8%3D"}],"group":"cf-nel","max_age":604800}
< NEL: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
< Server: cloudflare
< CF-RAY: 694125262ce1319d-LAX
< 
* Connection #0 to host www1.smart-treasure.club left intact
test* Closing connection 0

Assume your host is also GoDaddy, GoDaddy is performing redirection. This is something you need to clarify with them.

Thank you very much for your reply. My host was not purchased from GoDaddy.If nameserver is set, the domain name will be controlled by cloudflare and cannot be changed from GoDaddy. Is that right

Your current issue is not about nameservers and DNS. Your nameserver is now Cloudflare and managing your DNS records. It’s your host trying to redirect HTTP to HTTPS from their side.

By the way, who is your host (where is your website hosted)? Cloudflare is not your host.

It’s other VPS businesses. My other domain names are normal

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.