SSL is not working , I am using free plan of Cloudflare

Domain: Codersandip.com
Hosting : Hostinger.in

I have pointed Nameservers given by Cloudflare and they are showing all ok in dashboard. But. My free version of SSL is not working.

Pls help me in this situation.

Appears to work for me.

  curl -Ikv https://Codersandip.com
    *   Trying 104.21.74.117...
    * TCP_NODELAY set
    *   Trying 2606:4700:3036::6815:4a75...
    * TCP_NODELAY set
    * Connected to Codersandip.com (104.21.74.117) port 443 (#0)
    * ALPN, offering h2
    * ALPN, offering http/1.1
    * successfully set certificate verify locations:
    *   CAfile: /etc/ssl/cert.pem
      CApath: none
    * TLSv1.2 (OUT), TLS handshake, Client hello (1):
    * TLSv1.2 (IN), TLS handshake, Server hello (2):
    * TLSv1.2 (IN), TLS handshake, Certificate (11):
    * TLSv1.2 (IN), TLS handshake, Server key exchange (12):
    * TLSv1.2 (IN), TLS handshake, Server finished (14):
    * TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
    * TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
    * TLSv1.2 (OUT), TLS handshake, Finished (20):
    * TLSv1.2 (IN), TLS change cipher, Change cipher spec (1):
    * TLSv1.2 (IN), TLS handshake, Finished (20):
    * SSL connection using TLSv1.2 / ECDHE-ECDSA-CHACHA20-POLY1305
    * ALPN, server accepted to use h2
    * Server certificate:
    *  subject: C=US; ST=California; L=San Francisco; O=Cloudflare, Inc.; CN=sni.cloudflaressl.com
    *  start date: Feb 20 00:00:00 2021 GMT
    *  expire date: Feb 19 23:59:59 2022 GMT
    *  issuer: C=US; O=Cloudflare, Inc.; CN=Cloudflare Inc ECC CA-3
    *  SSL certificate verify ok.
    * Using HTTP2, server supports multi-use
    * Connection state changed (HTTP/2 confirmed)
    * Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
    * Using Stream ID: 1 (easy handle 0x7fee30008800)
    > HEAD / HTTP/2
    > Host: Codersandip.com
    > User-Agent: curl/7.64.1
    > Accept: */*
    >
    * Connection state changed (MAX_CONCURRENT_STREAMS == 256)!
    < HTTP/2 200
    HTTP/2 200
    < date: Sat, 20 Feb 2021 20:42:34 GMT
    date: Sat, 20 Feb 2021 20:42:34 GMT
    < content-type: text/html; charset=UTF-8
    content-type: text/html; charset=UTF-8
    < set-cookie: __cfduid=d13fd4fd3e6ab8eb2236b3ba2f45a54451613853753; expires=Mon, 22-Mar-21 20:42:33 GMT; path=/; domain=.codersandip.com; HttpOnly; SameSite=Lax; Secure
    set-cookie: __cfduid=d13fd4fd3e6ab8eb2236b3ba2f45a54451613853753; expires=Mon, 22-Mar-21 20:42:33 GMT; path=/; domain=.codersandip.com; HttpOnly; SameSite=Lax; Secure
    < x-powered-by: PHP/7.2.34
    x-powered-by: PHP/7.2.34
    < link: <https://codersandip.com/wp-json/>; rel="https://api.w.org/"
    link: <https://codersandip.com/wp-json/>; rel="https://api.w.org/"
    < link: <https://codersandip.com/wp-json/wp/v2/pages/6>; rel="alternate"; type="application/json"
    link: <https://codersandip.com/wp-json/wp/v2/pages/6>; rel="alternate"; type="application/json"
    < link: <https://codersandip.com/>; rel=shortlink
    link: <https://codersandip.com/>; rel=shortlink
    < x-turbo-charged-by: LiteSpeed
    x-turbo-charged-by: LiteSpeed
    < cf-cache-status: DYNAMIC
    cf-cache-status: DYNAMIC
    < cf-request-id: 0862c716b20000050bdaa0f000000001
    cf-request-id: 0862c716b20000050bdaa0f000000001
    < expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    < report-to: {"group":"cf-nel","max_age":604800,"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=NKaPhVwILddXqWTppFJCnl9KDxHh2tYNeo2FQ769cQbGWrZ2L%2FoB%2BtUscVyicCOYBZYIkXzd41krszYP14RajxaTOXJfTsoeseEwG4pDGMs%3D"}]}
    report-to: {"group":"cf-nel","max_age":604800,"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=NKaPhVwILddXqWTppFJCnl9KDxHh2tYNeo2FQ769cQbGWrZ2L%2FoB%2BtUscVyicCOYBZYIkXzd41krszYP14RajxaTOXJfTsoeseEwG4pDGMs%3D"}]}
    < nel: {"report_to":"cf-nel","max_age":604800}
    nel: {"report_to":"cf-nel","max_age":604800}
    < server: cloudflare
    server: cloudflare
    < cf-ray: 624b0e045bac050b-LAX
    cf-ray: 624b0e045bac050b-LAX
1 Like

Hi @cscharff Thankyou for replying.
My Chrome Android browser is something showing SSL and sometimes not.
Opera browser for Android : not showing ssl
Chrome Windows : not showing ssl
Brave Windows : not showing
Microsoft Edge Windows : not showing

I am waiting since 7 8 hours by thinking that it will fix automatically , but not.

I have cleared cache also. Can u help me please or if you can explain me the issue, I will be grateful to you.

What version of Android are you running?

What “Minimum TLS” option have you got selected at your Cloudflare dashboard?

I can confirm it loads up at my end.

Hi @fritexvz I am using Android 10 and minimum TLS is set to 1.0

Are you using WiFi or mobile data on your mobile phone?

If on home or public network, can you try to restart your router?

Can you reach your website without HTTPS (only HTTP)? - or due to Cloudflare settings, it should redirect you to HTTPS.

I can’t get mine to work either…

galaxyheadliners.com

I know it’s probably my fault but would appreciate someone helping out if they could !

James

Sorted it !!! Thanks guys !!!

The solution which I found is we need to have our original hosting server in HTTPS, i.e, we have to install a certificate in our main hosting server in order to get a stable connection otherwise sometimes it may create problems. Pls see this >> SSL free registration not working - #8 by sandro