SSL is not secure

#1

I have set up my cloudflare and it says I have a registered valid HTTPS but it isn’t showing the lock button to dictates it security. I have tried disabling and re-enabling the universal SSL. But it just isn’t working, can someone help me please.

The domain name is: cuttingedgetalent.co.uk

0 Likes

#2

Do you have a valid certificate on your server? Also, whats the domain?

0 Likes

#3

Yes I do and the domain is: cuttingedgetalent.co.uk

0 Likes

#4

The usual mixed content.

You are still loading a few images via HTTP. Fix that and the warning should disappear.

1 Like

#5
0 Likes

#6

Wasn’t the way to fix this by enabling always HTTPS? Is that’s the case I already enabled that and it still doesn’t work

0 Likes

#7

That will redirect HTTP requests which in fact happens, but the browser still gets an HTTP link. Somewhere in the settings there is also a rewrite-to-HTTPS option. Enable that and it might fix the issue as well, but generally speaking I’d search for mixed content here (that issue comes up every few seconds) and follow @Withheld’s link.

0 Likes

#8

I followed the link and it gave two solutions both of which I’ve tried the automatic HTTPs rewrites. However the page is still not showing a secure connection

0 Likes

#9

Then it might not work in your case. Continue searching, there is plenty of information here on the forum on that subject.

2 Likes

#10

The images @sandro mentions will load over https. I think they are being called from a script and as such, automatic rewrites won’t work. You need to manually update from http to https, or just follow the directions in the first Resolution item in the link from @Withheld. If this is a wordpress site, check out the recommendation under the resolution section.

1 Like

#11

Clear your browser cache, it’s working fine now.

1 Like