Ssl / https not working


#1

Hi. Firstly I have read the similar questions and related answers but they have not fixed my problem.
The reason I signed up for Cloudflare was because we are moving a website to a different server that does not have ssl. The problem is the home page is indexed in search engines as https://onkohrong.com so this returns an error clicking on an https search engine link.

'Your connection is not secure

The owner of www.onkohrong.com has configured their web site improperly. To protect your information from being stolen, Firefox has not connected to this web site.’

My understanding was that using cloudflare the https request would be accepted and normal http passed to my server.

I have checked in overview -
site is active and ssl is flexible.
I have checked in Crypto and it says ’ Universal SSL Status Active Certificate’
I have tried all combinations of ‘always use https’ and ’ Automatic HTTPS Rewrites’ I am not sure if I need to change ’ Opportunistic Encryption’ if this will have any effect.

Please, any advice much appreciated

Kerry


#2

Hi @kerry, I just visited the site and it loads securely at https://onkohrong.com/


#3

Hi - yeah just tried it all ok now - thanks


#4

Even thought it says certificate active still need to give it 24 hours - just adding this to help others


#6

Thanks a ton kerry and thanks for the thread. It saved me from a lot of hassles. Appreciate it very much.


#7

seems like that is what this site is all about - very impressed so far