SSL & HTTPS Not Working


#1

I setup an account with Cloudfare and made these changes to support SSL and HTTPS on my website (www.verajuris.com). However, it has been two days since I made the updates and the site is still not showing as being secure with HTTPS. Below is the Crypto status from Cloudfare. It says that I have an active certificate. Can anybody help me get this working properly.


#2

Your website is available via SSL: https://www.verajuris.com/

You should turn on “Always use HTTPS” as well as “Automatic HTTPS Rewrites” on that crypto tab, this will make sure all resources are loaded over HTTPS including the main page.


#3

Thanks! It is working now.


#4

I have another issue now. When using the Chrome browser on my web site (www.verajuris.com) I don’t see “Secure” to the left of the URL. Instead, I see a circled letter “i”. When I click on that icon, I see the following message saying that the site is not fully secure. What do I need to do in order to get it fully secure?
image


#5

That’s a Mixed content error, your website’s CSS and JS files have many links to http:// when it should be // or https://. see The following article for more info


#6

I am having the same issue (the site is still not showing as being secure with HTTPS) - here is a screenshot for my website www.offthewallartgallery.com - please help!

Crypto

Manage cryptography settings for your website

SSL

Encrypt communication to and from your website using SSL.

It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.

Universal SSL Status Active Certificate

This setting was last changed a day ago


#7

I am having the same issue (the site is still not showing as being secure with HTTPS) - here is a screenshot for my website www.offthewallartgallery.com - please help!

Crypto

Manage cryptography settings for your website

SSL

Encrypt communication to and from your website using SSL 1.

It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.

Universal SSL Status Active Certificate

This setting was last changed a day ago


#9

I had the same problem and changing those settings has cleared the problem.

Thanks!


#10

Neither your root or www appears to be :orange: so traffic is not being proxied by Cloudflare.


#11

I have followed the steps provided by Homestead ~ but it says not to proceed to “step 12” until my website appears at HTTPS ~ it has been two days. What should I do?? Please advise. Thank you very much!!


#12

In the screenshots previous to step 12 they have the records for the root domain and www set to :orange: yours are set to :grey:. While the site is :grey: it will not proxy through Cloudflare or show it available through https, so that should be changed to :orange: for those records.


#13

I think I did what you mentioned…waiting patiently now for HTTPS to show…thanks!


#14

I note you are now redirecting all URL versions of your verajuris.com website to https://www.verajuris.com
i.e.
http://verajuris.com redirects to https://www.verajuris.com
https://verajuris.com redirects to https://www.verajuris.com
http://www.verajuris.com redirects to https://www.verajuris.com

However you are using more redirects than necessary.
See https://varvy.com/tools/redirects/
Too many redirects may cause performance and indexing issues.

I configured the .htaccess file in the root folder/directory of my domain with the following;

BEGIN redirect all example.com URL variations to https://www.example.com

RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www. [NC]
RewriteCond %{HTTP_HOST} ^(?:www.)?(.+)$ [NC]
RewriteRule ^ https://www.%1%{REQUEST_URI} [L,NE,R=301]

END redirect all example.com URL variations to https://www.example.com

And removed all other instances of redirect directives (including cloudflare).
These configuration directives are not perfect, but they do result in no more than two redirects for any URL variations.


#15

this is how I fix regarding your issues https://community.cloudflare.com/t/error-message-future-home-of-something-quite-cool/28442/32?u=bimasaktie


#16

This topic was automatically closed after 31 days. New replies are no longer allowed.