SSL handshake - uknown error

Hello,
Direct https connection to my server works from my embedded device (with a Let’s encrypt certificate), when introducing cloudflare, there is no returned error code, and requests are not even reaching the cloudflare’s firewall, the connection is disconnected before any response.
I tried both Google and Let’s Encrypt certificates on Cloudflare, but same result.
I do not have full control on the embedded device, I can see some basic logs, and I can change the server’s URL.

Is there a way to see the handshake log on cloudflare? my problem might be the ECDSA , is there a way to use a certificate without ECDSA , without passing to Enterprise edition?

Thank you

Just to add more details about my request.
I disabled the “Browser integrity option”, but same error when testing from my embedded device.
I tried also the developer mode to allow all packets to pass, by it is not working, it is failing at the handshake level.
I am able to make the following tests successfully:

  • Testing from Postman
  • Testing from a browser (GET requests)
  • Testing from curl and changing the Agent to the same agent name used in my device.
    Thank you

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.