SSL handshake failed error code 525 on my subdomain

It has been more than a week since I created a subdomain:

but continuously getting the “SSL handshake failed error code 525” only in this subdomain.
The SSL option I have selected under the [SSL/TLS tab] at Cloudflare dashboard for my domain is full.
Before moving to Cloudflare my Website was working over an HTTPS connection.
I only got this problem on my subdomain mentioned before.
When Use the “Pause Cloudflare on Site” option from the Overview tab for my domain I get this message unexpectedly closed the connection. but all the other subdomains work perfectly.
I found some of your answers on the community to make the SSL option Fll strict, same problem this subdomain does not work but all of the other subdomains work properly.
PS: all the subdomains I have created them on another registrar which is GoDaddy but the one in which I have the problem I have created it in Clouflare, meaning after I have changed the DNS.

I tried all the solutions but all have no effect, I hope you help me ASAP, and thank you.

And that’s precisely why Cloudflare throws the error, your server does not work properly and you need to contact your host on that. Keep Cloudflare paused until that works, as that simplifies debugging.

Unfortunately, that still does not provide security. It needs to be Full Strict.

1 Like

I’ve connected this domain to a blogger website, could you guide me on how I can contact them to fix my problem?

Afraid this is not Cloudflare related so you need to discuss this with your host. Maybe Google has not issued the certificate yet, so again keep it paused until it loads fine on HTTPS, then it should also work on Cloudflare.

It says:

Status: Failed - HTTPS SSL Certificate failed to be processed due to challenge data not being visible through the public internet. Check your DNS setup. The operation will retry shortly.

Precisely, they did not issue the certificate. See my previous response.

So you’re saying that I have to turn off the SSL/TLS encryption mode till it is fixed from Google then I can switch to full strict mode right.

No, the encryption should always be Full Strict.

Ok, thank you so much.
one last question: I don’t know how to pause Cloudflare.
and thank again for helping me

You paused it before, right?

1 Like

Oh YEAH, I totally forgot that.
Have a nice day

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.