SSL HandShake Failed | Error 525

Error 525


Tried all the fixes and its not working… i use Cloudflares SSL Aswell… was working this morning, havnt changed anything, and its just stopped working

If it was working earlier and now it is not, then something must have changed on the server. Did the certificate on the server expire?

The certificate Is Active.

If you pause Cloudflare on the site, does SSL work correctly?

how exactly do i pause Cloudflare?

Edit: just figured it out, lemme try

If you go to the overview tab for the domain, you will see the option in the bottom right:


i paused Cloudflare, and when i go to the site, i still get Error 525

That will be due to a cached DNS value, an online SSL checker reports:

No SSL certificates were found on Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server’s firewall.

How could i fix this?

You will need to make sure that you have a valid certificate installed on your server. You could ask your web host for help with fixing this. You can use a free Let’s Encrypt one or a Cloudflare Origin Certificate, or one from another provider.

should i just disable Cloudflares ssl and Move to A Different ssl from a different company?

Right now your server generally returns a 408 error. Also, SSL is not configured either for your server.

Neither of both is a Cloudflare issue but needs to be fixed on your server instead.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.