SSL Handshake Failed (cgpproducts.com)

I have been going back and forth with my host (inmotion) about this issue and they are seeing no problems with the SSL certificate etc. However using GTmetric or pingdom all i can see is this SSL error.

https://gtmetrix.com/?job_error=dTxVWF77

The website is - www.cgpproducts.com

My co workers are also seeing the error on their end but on my end it works in some browsers and other times it doesn’t… Im honestly out of ideas of what the issue is.
Any help would be appreciated as Inmotion are saying its fine on there end as stated before.

Even WHOIS sometimes, like whois.domaintools.com output knows to be “Response code: 500” and " 500 SSL negotiation failed:".

Could be due to the DNS cache on the ISP side?
Does their Web browser support SNI?
Do you use “Flexible SSL” or “Full SSL”?

Try to look up here, if already did not:

Reproducible at sitemeer.com/#https://www.cgpproducts.com/

Best guess, your host blocks requests from certain Cloudflare datacentres respectively does not respond properly to SSL connections. Thats something for your host to clarify I am afraid.

I have Full SSL enabled. When using the likes of Flexible the page wouldnt even load at all.

I did take a look at that list also. The thing is it was fine before, and ive been running cloudflare alongside for years. All of a sudden this has started happening…

I ran into this as well – same fix. No idea why the default Cloudflare SSL setting suddenly stopped working. Switching to Full magically fixed it, though I don’t feel confident about this type of change.

This topic was automatically closed after 30 days. New replies are no longer allowed.