SSL handshake error on page

I am getting an SSL handshake error on one of my pages. GoDaddy says its TLS 1.0 settting issue on Cloudflare but I don’t know how to adjust it


I would suggest, as a first step, checking your TLS settings in Cloudflare:

  1. Log in to your Cloudflare account.
  2. Select the domain for which you want to adjust the TLS settings.
  3. Go to “SSL/TLS” > “Edge Certificates”.
  4. Scroll down to the “Minimum TLS Version” section.
  5. Check the current setting and if it is set to TLS 1.0 (t’s generally recommended to use TLS 1.2 or higher to ensure better security and compatibility).
  6. Select the desired TLS version from the dropdown menu.

You can find an explanation for this in the documentation in:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.