SSL Handshake Error (Cloudflare Proxy)

I have trouble setting up Cloudflare proxy.
A record: -> (No Proxy)
CNAME record: -> (With Proxy)
SSL mode is “Full”

Output of cURL:

curl: (35) error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure

I tried a Let’s Encrypt certificate and also a Cloudflare origin certificate.
Also i tried a Let’s Encrypt certificate for “” and “” with the same result.
Access by browser also doesn’t work.

How am i supposed to setup my ssl certificates to use the proxy function by Cloudflare?

The Cloudflare universal certificates cover and *
This means that it covers any subdomain one level above the domain you signed up with. It will cover and, as these are one level above the root domain, The certificate will not cover or, however, as these subdomains are too deep.

You can read more about this and the solutions in this community tutorial.


That is indeed the problem, thank you!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.