SSL - GoDaddy - wordpress issue


#1

Hello everybody!
I’m writing after reading all similar topics but still not solving my problem.

I added cloudflare free ssl for my wp site gracealfisz.com I installed it flexible and had the really simple SSL plugin installed I put it on maintenance mood on w/an elementor template. but when trying to edit my theme I was having e 520 error so I leave it for that day. Next day when I tried to login on wp-admins was impossible, not even holding on the plugins at Cpanel or anything. Cloudflare was running OK and Goddadys “support” says it was a Cloudflare problem.
At the end the only “solution was reinstalling everything from zero. This time I got the CloudFlare Flexible SSL plugin + the Force HTTPS instead the Really Simple SSL, Also made 3 page rules including wp-login.php* and wp-admin* which I think is what is helping me to not being kicked out from wp admin again hahaha but I still have the same 520 error when trying to edit any page, nothing is helping not even changing theme, or deactivating elementor…:woman_shrugging:
I have Editor Loader Method on, rocket loader off.

I must say (as you probably can guess) I’m a non-techie person at all so i’m scratching my head trying to solve this but really cannot find how.

Hope anyone can help me! Thank you in advance


#2

You should probably back up a bit and not use Page Rules (for now).

Flexible SSL really makes things more difficult with Wordpress. Give this a try:


#3

Hi again!
So I just did it, configure the ssl strict on cpanel and I’m still having the same issue (It happens when I try to edit any page, doesn’t happen when personalizing themes or coming soon template those are working ok):

I must say I did not erase the page rules yet cuz I’m afraid I’ll loose access to the wp-admin as already happended the first time.
Should I? also should I uninstall cloudflare &/or Force https pluggins?

Thank U!!!


#4

A 520 is probably security protection blocking the request.

Now that SSL seems to be ruled out, see how it works without Cloudflare:
From the Cloudflare dashboard’s Overview section, click “Pause Cloudflare on Site” in the lower right corner.

Wait 5 minutes for DNS to update, then give the editor a try.

Back to the 520…have you checked server logs for the activity that’s getting blocked? It might be in a log that only GoGaddy has access to.


#5

Hi again, well I dont know where to check it :sweat_smile:
In metrics/errors I found this:

[Fri Dec 14 04:31:02.086391 2018] [access_compat:error] [pid 3131180:tid 140474056611584] [client 172.69.134.193:10754] AH01797: client denied by server configuration: /home/x4v6r9w8vz2p/public_html/wp-includes/js/crop/wawa.php, referer: http://site.ru
[Fri Dec 14 04:30:59.393296 2018] [access_compat:error] [pid 3131184:tid 140474245428992] [client 172.69.134.199:19714] AH01797: client denied by server configuration: /home/x4v6r9w8vz2p/public_html/wp-includes/js/crop/wawa.php, referer: http://site.ru

Is it giving any useful info?
Thx


#6

This topic was automatically closed after 30 days. New replies are no longer allowed.