SSL From Cloudflare and Hosting

Hi Everyone,
My domain is visiasia.co.id hosted in DigitalOcean.

OVERVIEW
Before I connected my domain to CloudFlare, I have already setup the SSL via terminal using Let’s Encrypt.
And today I have just connected it successfully to CloudFlare without any problem.
Then I set the full encryption with SSL from my CloudFlare account (Check the image from link below)
CloudFlare Full SSL
I have also setup the Wordpress setting on my domain to direct it to https (Check the image from link below)
Wordpress URL HTTPS

CONFLICT / PROBLEM FACED
When I tried to access the domain using Chrome, the domain is running under HTTPS automatically.
But when I tried it on Firefox, the domain has problem with the SSL.
Firefox Access

QUESTION
How can I resolve this issue?
What is the problem here?

Regards,
Hexa

Hi Hexa,

For me even in Firefox, it works without issue. The only thing I noticed is that your domain doesn’t automatically redirect to HTTP, neither in Chrome nor in Firefox. I will have to go to the HTTPS version by manually typing out HTTPS:// in front of the URL.

Have you tried turning on “Always Use HTTPS” under SSL/TLS -> Edge Certificates or “Automatic HTTPS Rewrites” under that same menu?

Hi Knagie,
Thanks for the reply.
Yes I did it, I have turned on both “Always Use HTTPS” and “Automatic HTTPS Rewrites” under the SSL/TLS menu on my CloudFlare account which pointed to my domain.

I even tried to put a rule to force HTTPS using .htaccess, but when I did it, the site will not be accessible anymore, the error message says too many redirection.

Some other suggestions that come to mind:

  • If you use .htaccess and the rewrites in CF that might be a reason for the too many redirects. Try removing the CF ones and only using .htaccess and see if that changes that behavior.

  • Is Wordpress installed in you private_html directory and not in your public_html? (Some hosts have different directories based on HTTP or HTTPS)

Edit:
After retrying now it seems to redirect to HTTPS like normal in FF as well as Chrome (Private/Incognito tabs as well) does this work for you as well?

I have just tried to turned off the SSL from CF and activate the rule to force SSL from .htaccess.
But now the error message saying that it is not redirecting properly.

BTW for your information, before I connect this domain to CF, I have had installed the SSL by using command on putty. Can this be a problem too? Should I remove it first?

I can’t seem to reproduce that error, have you tried it in an incognito/private window as well. Looking this error up in Google shows some people solved it by removing the cookies + cache for that specific domain. Which could make sense as well since you have tried and loaded it with other settings before.

I would suggest going for CF as the SSL cert provider, so yes removing that on the host might also help. Not sure what would happen if you have two SSL certs for the same domain from different requests actually.

I forgot to mention about it, yes I always open my site on incognito.
I never leave any cookies and cache on all of my browsers.
I will try to remove the SSL from my server.
And BTW for more information, I use RunCloud to manage my droplet in DigitalOcean.
So basically my hosting is using a managed platform and I deployed the server using RunCloud.
I even installed Wordpress by using their “1 click install” feature.

I have just uninstalled the SSL on the server side by using command.
image
But now I can’t even access the domain anymore from FF and Chrome.

I tried to install back the free SSL.
But now it comes with this error message: