SSL flexible active but not secure https

dash-dns
dash-crypto
#1

Hi all,
I have the active SSL certificate with flexible and my site is added but when I use https it still shows a crossed out https in front of the not secured. how should I fix it?
my site is ucook514.ga
Also, the dashboard is all weird and does not load properly after I have move nameservers to Cloudflare. can someone comment?

thanks in advance.

#2

I see a DNS error as you don’t appear to have any DNS records in Cloudflare, please see:

Also, Flexible is not recommended if you can avoid it. Why we recommend you don't use flexible!

1 Like
#3

Thanks Domjh, I am adding the A, AAAA, I don’t know where to look for ipv6 address. Is it the same you have shown in the image?
I have seen many tutorials and they always recommend to select flexible because it free?

waiting for your reply.

thanks

#4

Hi,

You will need to add the DNS records that are specified by your web host. They will likely just give you one IP address to add as an A record and you won’t need any AAAA.

All 3 SSL modes are free in Cloudflare, Flexible is often recommended as it can be the easiest to setup. To enable one of the secure modes (Full or Full (strict)), you will need an SSL certificate installed on your server. This can be one from your host, a free Let’s Encrypt certificate or a free Cloudflare Origin Certificate (you can generate one in the crypto tab of the Cloudflare dashboard).

#5

Hi, Can you look at my DNS records to see if that looks ok.
I am very new to this that’s why I am confused.

thanks for the reply

#6

Would you mind posting screenshots? The community doesn’t have access to your account.

#7

sure, here it is

#8

All these tutorials are rubbish - sorry for being blunt, but it is the truth. Flexible is not secure as your data is still transferred via unencrypted HTTP.

For a secure site you definitely need a certificate on your server. These are free anyhow, either via Cloudflare’s origin certificates or via Lets Encrypt.

1 Like
closed #9

This topic was automatically closed after 30 days. New replies are no longer allowed.