SSL Failing? New Account


#1

Changed nameservers on free account, things seemed to be working ok, upgraded to pro and noted site loading began to fail. Not sure if it’s related but we’re experiencing complete site outage at this point and am looking for some direction.

site: https://modthread.com

Support ticket is in, but no idea when we should expect a response.

Anyone here able to provide guidance?


#2

I’d try to disable universal SSL, wait about 15 minutes, and re-enable it.


#3

Will try and report back.


#4

@sandro Should I re-enable to Flexible or Full? Does it matter?


#5

Generally it should always be Full, Flexible should be used only in very rare cases.

However, these settings are unrelated to what I meant. You switched to “Off”, right? I meant “Universal SSL” at the very bottom of the page.


#6

@sandro I see. Just disabled universal. Ok to leave SSL to OFF for now? Once re-enabling universal, would I change anything to the attached image?


#7

The SSL setting of your screenshot is a bit of a mess as it touches two areas, the connection to your server and the one from the user to Cloudflare.

But for your issue it is not much of relevance, as the certificate itself appears to be the issue, which is only controlled by the universal SSL setting (unless you’d have a dedicated one). So just disable universal SSL, wait these 15 to maybe 30 minutes, re-enabled it, and check if you have a proper certificate.

The setting in your screenshot should still not be “Off” though, otherwise you’d always get a redirect to HTTP.


#8

@sandro Re-enabled and the new cert is now authorizing. Is there a way to verify the cert is new and accepted, prior to it being authorized by CloudFlare?

Getting a little worried with how long our site has been down at this point.


#9

It appears the certificate now works, the site is loading.


#10

It’s solved. Thanks for the help, Sandro.


closed #11

This topic was automatically closed after 31 days. New replies are no longer allowed.