Ssl error subdomain

dash-dns
dash-crypto
#1

Good evening everyone, I have a problem with my subdomain https://status.skybot.me, it puts me as error: Error SSL handshake failed.

What can I do ?

#2

You need to install a certificate on your server. If you use ‘Full’ SSL mode, then any cert (including self-signed) will do. If you use Full (strict) (which is the best option), then you will need a valid cert. You can get a free Cloudflare origin certificate, use a free Let’s Encrypt cert or any other valid certificate.

#3

How can I generate a CloudFlare certificate? Because I contacted my host but they tell me that I will generate in certificate on CloudFlare

#4

Here are the details on Origin Certificates:

You will still need to install it on your server once it is created though.

#5

I did but it still does not work …

#6

Something must be wrong with the config on the server if you did install the certificate. You could set the DNS entry for ‘status’ to :grey:, then work out any issues with the certificate with your host and make sure you can see the cert in your browser (you will get an SSL warning with an origin cert when set to :grey:) and then set it back to :orange: and you should be good to go.

#7

I still have the same mistake …

#8

You should contact your host for help installing the certificate on your server then. Now you have generated it, they should be able to provide a tutorial / walkthrough to help you install it.

#9

It can not be the port that is problematic?

#10

What port are you using?

#11

I do not know, how can I know?

#12

Check with the host. Something on the server is broken.

1 Like
#13

What ?

#14

Set your Cloudflare Dashboard DNS entry for ‘status’ to :grey: and tell your host to fix their SSL.

1 Like
#15

I installed the CloudFlare certificate, but I still have the same problem … I have to wait?

#16

But on this domain I pointed the page on stats.uptimerobot.com, it is perhaps that which poses problem No?

#17

Ah, it’s a CNAME to Uptimerobot. You can just leave that one set to :grey: in DNS. Uptimerobot uses Let’s Encrypt for custom status pages. Your web host has nothing to do with this, as Uptimerobot is not hosted there.

If it gives you an SSL error when set to :grey:, then something is wrong with the certificate at Uptimerobot.

https://blog.uptimerobot.com/status-pagescustom-domains-are-now-https-enabled/

1 Like
#18

good ?

#19

And on Uptimerobot in Settings, did you set up the Public Status Page with your custom domain?

#20

Yes I put status.skybot.me, but I still have the CF error page, I have to wait?