SSL Error: *.subdomain.domain.tld


#1

I am getting the following error when I turn on HTTP Proxy:

This site can’t provide a secure connection

subdomain.subdomain.domain.tld uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

When HTTP Proxy is turned off the site resolves correctly and is secured using the Let’s Encrypt SSL certificate loaded on the webserver. It’s only when HTTP Proxy is enabled that the error appears. I believe is has to do with the Universal SSL (Shared) that Cloudflare issues. The certificate shows as issued, but it is only for domain.tld and *.domain.tld. How do I get Cloudflare to issue a Universal SSL (Shared) for *.subdomain.domain.tld?

Any help is greatly appreciated.


#2

Correct, Universal SSL doesn’t support a fourth level subdomain. You’d have to pay for a Dedicated Cert with Custom Hostnames and manually enter that fourth level subdomain.