SSL error? Shows Sitemap on home page

Hi, I believe I may have an SSL issue. It is showing my sitemap when loading the home page [https://www.myflyingleap.com], but when I removed the s (http://myflyingleap.com) the home page shows correctly. This was not an issue before I added Cloudflare to my site, so I believe it is associated.

I searched the SSL errors in this forum and I’m not seeing one that shows this error from what I see.

I found an article that suggested changing the SSL to Flexible (instead of Full) and adding a plugin called Cloudflare Flexible SSL). Still not working.

article: https://geekflare.com/Cloudflare-ssl-breaks-wordpress-joomla-how-to-fix/?fbclid=IwAR3T9s543iwqi50RbNOG2tAHFURO8yElPwA0i3_ZDRuZvDBQEkBP9lmlmUk

Any ideas? I believe I should use full, but either way, I don’t know how to fix this.

I really appreciate it,
Samantha

Hi @samglauser, you have a mixed content issue with a script on your site. In Chrome, look for the small shield and red x in the right side of the address bar. Select load unsafe scripts and your page will look like you expect, I expect.

Here are the details. Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

2 Likes

Thank you, @cloonan! I really appreciate your taking the time to help.

Happily, and welcome. How’s it on making the changes?

I will confess I’m a bit out of my element with this (I’m a writer not very technically inclined) so I shared this with my tech guy- dad. He sent this:

On your wp-admin Settings/Cloudflare settings security

I turned on

Automatic HTTPS Rewrites

And it appears to have fixed it. I work with a developer on occasion so will send him your message as well so he’s aware (for the last part of your message) to see if he thinks we should do something further.

Thank you, and have a great day.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.