SSL_ERROR_NO_CYPHER_OVERLAP problem

Okay so this is very weird. I have multiple sub domains which are all being proxied by CF right now. However, two of them return: SSL_ERROR_NO_CYPHER_OVERLAP.

My domains:
cnftswap.me (server A) ← OK
api.cnftswap.me (server A) ← OK
wss.cnftswap.me (server A) ← OK
testnet.cnftswap.me (server B) ← OK
testnet.api.cnftswap.me (server B) ← SSL_ERROR_NO_CYPHER_OVERLAP
testnet.wss.cnftswap.me (server B) ← SSL_ERROR_NO_CYPHER_OVERLAP

I really don’t understand the problem. I tried the following things:

  • I use the ‘full’ SSL mode. I changed it to ‘full (strict)’.
  • Disable and enable universal certificate.
  • Disable and enable proxying for the two sub domains.
  • Restart NGINX webserver.

When I disable the proxying for those two sub domains, it works. It will then just use my letsencrypt certificate. But when proxied I keep getting the error.

Can anyone help me out?

Greetings,

Thank you for asking.

Seems to me like an issue as described more in detail at the article from below provided with the solution to this while using Cloudflare :orange: and Universal SSL for those specific sub-sub-domains:

You would have to use Advanced Certificate Manager:

1 Like

Ah! That was it.

firefox_yrcy1XkM8E

God I feel so stupid I didn’t see this before. Thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.