SSL_ERROR_NO_CYPHER_OVERLAP Out of Nowehere!


#1

Hello -

I have read a few posts here already about this error message but my situation is a little different. My domain has been set up since 2016 and the SSL status has be “Active” ever since. I did migrate my site to a new host back in December, but even since then there have been no issues until 10pm 3/2/2018.

I do have a Comodo Wildcard Cert that has been installed for the same amount of time and everything has been working fine until tonight. My main domain is showing the above error, however my sub domain (same server) works completely fine. How can this be?

If I “pause” Cloudflare, my site comes back up, if I “unpause” it, it goes back to the same error? What is going on with cloudflare that a Cert just goes missing out of nowhere causing my site to go down?

Any insight would be appreciated. Thanks.


"Secure Connection Failed" for originsofmotion.com - been fine for 4 months
#2

It sounds like the Cloudflare cert for your main domain is broken. I believe if the cert on your server was messed up, you’d get one of the Cloudflare errors with a diagram showing a break between Cloudflare and your server.

If you’re daring, you can go to the Crypto tab and turn SSL Off, then back to Full (Strict) and see if that wakes it up. If not, open a Support ticket.

I’d also try an SSL test: https://www.ssllabs.com/ssltest/ (seems down at the moment) or https://www.htbridge.com/ssl/

I also try Chrome’s Dev Tools for their Security info.


#3

sdayman -

Thanks for the response, I had already ran the SSL tests on both the main domain and sub domain, again where the main was getting an error and the sub was not.

I did submit a ticket but I want to leave the issue in tact so that support can see for themselves. I can’t have the site down, so CF is currently paused and my Comodo Cert is protecting me server-side.


#4

It was a corrupted SSL Cert from Cloudflare, after reissuing a new Certificate with the addition of changing the Require Modern TLS setting to “On” helped resolved the problem. Back in business. Thanks.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.