SSL_ERROR_NO_CYPHER_OVERLAP and Unable to connect

My domain:

First, its been 24 hours and not all DNS have been updated (new nameservers should be elaine and jason.ns.Cloudflare)

Secondly, I keep getting “SSL_ERROR_NO_CYPHER_OVERLAP” - I tried SSL to be Flexible, and Fixed but sometimes I get this error and sometimes it says “Unable to connect. The remote host or network may be down.”

Never happened before. I have tried everything and am about to pull my hair. lols.

Hope someone can guide me

I am having the same issue. I changed registrar from Epik to Namecheap (Domain:

Everything is the same. I changed the setting in new registrar to new Cloudflare nameservers, but my site has become unavailable (it works with some VPNs) but for most users including myself, its unaccessible.

I even deleted the site from Cloudflare and re added it. same issue :frowning:


Propagation is yet to complete, however, CF does not seem to be either active or paused or set to :grey: DNS only.

1 Like

yes I removed it and added it again. Its been 24 hours, registrar is ok as domain resolves to: (Cloudflare) but then it doesn’t go to my website


Would you make sure the NS records are correct as I see there’s a difference.

1 Like

yes. double checked.

Some WHOIS is showing correct record, some are showing older.

The correct one is: and jason…

(old ones are luke and amber)

@ neiljay

can u pls check and help

still can’t connect. on my VPS, if i try to generate AutoSSL, I get the error: “DNS of your domain doesn’t point to this server or you have htaccess restrictions” (i double checked, no htaccess restrictions on my end from vps)

It looks to be related to DNSSEC. Seems, DNSSEC is not disabled & therefore, DNS is not being resolved. Here’s the information:

Follow this guide for the proper setup:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.