SSL Error in browser


#1

Hi,

I’m using x10hosting with Cloudflare and I can’t get the SSL to work.
The following https://stylelanka.lk, gives me the error ERR_SSL_PROTOCOL_ERROR in Chrome and SSL_ERROR_RX_RECORD_TOO_LONG in Firefox.
However the http url works fine.

The odd thing is that if I check here: https://www.sslshopper.com/ssl-checker.html#hostname=www.stylelanka.lk it looks like it should work fine?

This is a Wordpress page and I have installed the Cloudflare plugin.

Here are my Crypto page.


In addition I have “Always Use HTTPS” disabled and" Automatic HTTPS Rewrites" enabled.

I have also added a page rule for http://stylelanka.lk/ with the setting “Always use HTTPS”.

Anyone that can guide me in solving this?


#2

First of all, change that “Flexible” to “Full strict” or at least “Full”, otherwise your site wont be secure and we dont even need to continue. You do need a proper certificate on your server of course though.

Second, only your www host points to Cloudflare and seems to work but redirects to the non-Cloudflare naked domain which points straight to your host.


#3

Thanks for the quick reply Sandro.

I currently have the following in my DNS:
stylelanka.lk. 14400 IN A 198.91.81.6
www.stylelanka.lk. 1400 IN CNAME www.stylelanka.lk.cdn.cloudflare.net

What do I need to add/change to the this working correctly?


#4

I guess you were still replying to my initial response, which I edited in the mean time, right?

Your DNS setup looks okay for a partner setup but the issue is the naked domain which points straight to your host. You’ll need to contact your host in this case I am afraid.


#5

Thanks Sandro,

So this is not something I can change myself in the DNS settings?

I have my “WordPress Address (URL)” and “Site Address (URL)” set to http://stylelanka.lk
Can this be an issue? I read that it should be like this and have therefore not changed these to https.


#6

As @sandro said, you would need to contact your host about this as it appears to be a partner setup, as all these are different, we are generally unable to help with that kind of thing here.

If you are using Flexible (which I strongly advise against) then you need to leave it as http. If you changed it to https, you would experience a redirect loop.


closed #7

This topic was automatically closed after 30 days. New replies are no longer allowed.