SSL Error - Can't provide secure connection?

G’day crew,

I am very un-technical, but my site had been working perfectly fine for a number of months and today I went to open the website and was presented with the below error. I have followed other threads and tried to initiate their recommendations but I am still getting the same error on the https version of my site. Any ideas would be greatly welcomed.

Many thanks,

This site can’t provide a secure connection uses an unsupported protocol.


Hide details

Unsupported protocol

The client and server don’t support a common SSL protocol version or cipher suite.

The error “ERR_SSL_VERSION_OR_CIPHER_MISMATCH"" in Google Chrome prevents access to the site because it detects an issue with creating a valid connection to your site. This may be a temporary issue, and should resolve itself within 24 hours.
I would also check out this guide for more steps and information:


Thank you Jake. I had tried all the things in that post that I was technically capable of completing (I am not the most technical of guys), but will go through again and may just need to give it a little more time.

Appreciate your help.

Sounds to me like your SSL certificate expired and you have to renew it.

Kindly, may I ask you to:

  1. Temporary enable the “Pause Cloudflare on Site” option from the Overview tab of the Cloudflare dashboard.
  2. Or, temporary switch A www and A to :grey: (DNS-only).

Furthermore, contact your web hosting provider, or if experienced a bit more, if you are using cPanel, or maybe Let’s Encrypt, start the process of renewing / reissuing a SSL certificate for your domain(s).

Upon your Websites starts working and resolving over secured (HTTPS) connection, disable the option (or if you went with other way, switch back from :grey: to :orange: cloud).

Therefore, kindly check your SSL/TLS settings at the SSL/TLS tab of Cloudflare dashboard for your domain name and make sure it’s set to Full (Strict) SSL.

Hi Fritex,
Thank you for that advice. I haven’t tried what you have suggested and it is all within my technical skillset so I will try that now and let you know how I go. Very much appreciate you taking the time to help.


Hi Fritex, I have tried the suggestions above but I believe my ssl was the one provided with Cloudflare and so I disabled that and re-enabled it but I am not sure if there is any other way to renew the ssl certificate if it is this one?

I am still having the same issue after doing this

Hi Fritex, that solution may have worked. I have now found that the SSL is initialising so I imagine I just have to wait for that process to finish.

I will confirm when it is done but thank you very much for taking the time to help me with this solution. I didn’t realise the Cloudflare SSL certificates have a 3 month validity.

Thank you again.

May I ask does the word next to it state “Advanced” or “Universal”?

For the Universal SSL, yes, I remember this trick helped in some situations - but you still have to make sure you have got the SSL certificate installed and valid one at your server/hosting.

Hi Fritex,
The SSL I am using is the Universal one. It still says that it is initializing and cloudflare is where my website is hosted so I am assuming I need to wait for this Initializing status to shift to authorized or similar?

I would have thought it would have happened by now. I understand they allow for 24 hours but I gathered this was a grace period and they typically happen quicker?

May I ask did anything changed? Any updates?

I see your website is resolving over HTTPS using Cloudflare now:

G’day Fritex,

Thank you for following up. Yes, we are back up and running. The free SSL Certificate just seemed to remain ‘initializing’ and I couldn’t wait to have the site back up for a program I had so I ended up buying the Cloudflare SSL Certificate and that worked straight away.

It was a bit disappointing to have to buy it but I’ll re-look at how the free one works before this month is over.

I didn’t realise the free one’s seem to need to be re-issued every 3 months so I’ll be on to that next time.

Thank you again for your help - it certainly got me to land on the right place.


They should renew automatically a week or two before they expire.

Mine must have slipped through. I hadn’t made any changes to (or even touched) my account over the few months but the once active SSL was non-existent when I went in after having the HTTPS issues.

I will switch back to the free version (I don’t need much else) but the $10 was worth taking the hassle away for a month :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.