Ssl encryption mode

I was working on a website earlier it was working fine. But now it is show a 404 error and my ssl encryption mode is flexible, when i chance it to full or full (strict) it shows 525 error one day next day it works fine then next day again it shows 525 error.
Means when encryption mode is flexible it shows 404 error and when full or full (strict) then website works on alternate days.
I don’t why is this happening i somebody could help it would be great.

My website is mentioned in the screenshot

Also i ran Cloudflare diagnostic center and i am getting some errors.




  1. You are not using Cloudflare
  2. It actually loads fine →
  3. If it were on Cloudfare, only use Full Strict → Why you should choose Full Strict, and only Full Strict
1 Like

I disabled the Cloudflare for testing.
You can now check it again, it is showing same error.

Well, did you fix the encryption mode?

Right now its in flexible and as i mentioned it is not working properly in full or full (Strict) mode also.

I changed to full (strict) and now its showing 525 error.

That’s the right mode now.

It also works for some locations →

but not for all, which suggests that your server is blocking some Cloudflare datacenters. You’d essentially need to make sure that it does not block any of the addresses at

1 Like

How to do that, i am new to this.

You need to talk to your host about that, however your server generally has a configuration issue, it does not only throw an error in the context of Cloudflare servers.

$ curl -ik --connect-to ::[SERVER_IP]
curl: (92) HTTP/2 stream 0 was not closed cleanly: PROTOCOL_ERROR (err 1)

On HTTP 1.1 there’s no response either. Unfortunately that’s something only your host can fix.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.