SSL Edge Certificate taking more than 48 hours

Hello, it has been more than 48 hours since the order of the SSL certificate, but it has not yet been activated and is in the “Certificate Pending Validation” status.

Please help me, what I’m doing wrong?

How long has it been “authorizing” for? more than 48 hours
Have you contacted Cloudflare support? Yes, once.
If you have, how long ago and what is the ticket number? 1 day ago
What is the plan level for the domain in question? Free plan
What error, if any, is displaying on your site at the moment? My website is completely offline. Help!!
Are you signed up directly through Cloudflare or through a hosting provider/partner? Directly through Cloudflare

I presume you have only just added the domain to Cloudflare, so you can “Pause” Cloudflare which will send your users directly to the backend, which is probably where they were going before you added your site to Cloudflare.

Can you share the domain name?

Thanks for your prompt reply!

Domain: stevendecuba.com

That domain looks OK (on mobile so cannot do a thorough check). NS looks fine, and no CAA records that would get in the way.

You can try disabling SSL at the bottom of the TLS/SSL app on the Cloudflare dashboard, leave disabled for 10 minutes, then reenable and see if it validates.

I did that last night and tried this morning again… still no results.

I’m really confused. :frowning:

Still no change… any help?!

It looks like Cloudflare is only providing DNS for this domain. Naked domain redirects to www, which is on Kajabi, but Kajabi/Heroku does not have a valid certificate for your domain. You need to take this up with them, as the connections are going directly to them.

My apologies for my lack of tech knowledge. I don’t understand how Kajabi has anything to do with the Pending Validation of the Certificate? I’m following a tutorial on their website but it has been more than 48 hours since I’ve tried to get the certificate.

I appreciate your support.

Sorry, I misunderstood. Since the site isn’t working, I’d suggest setting both DNS entries (www, and stevendecuba.com to :orange: (Or UnPause, if that’s what you did) and re-try @michael’s suggestion of Disabling Universal SSL at the bottom of the SSL/TLS page, then wait ten minutes before re-enabling.

It shouldn’t take the full 48 hours, but if it doesn’t issue a cert in 12 hours, open a Support ticket:

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

I’ve indeed pause it. I’m going to unpause it now and re-try @micheal’s suggestion.

Just to be sure I’ve this DNS entry:

CNAME www, stevendecuba.kajabi.com.

What else should I add?

Again, excuse for my lack of tech knowledge. It scares the ■■■■ out of me!

I’ve also opened a support ticket. I’m guessing I need to wait until Monday?

That’s all you can do.

At its core, you’re using Cloudflare DNS to point your domain to Kajabi. I’m concerned that Kajabi isn’t configured with a valid certificate for your site there. Before you unpaused Cloudflare, I could have sworn I got a result when looking for www.stevendecuba.com that pointed to Kajabi and resolved, but stevendecuba.kajabi.com doesn’t have a DNS record.

You should get an automated reply on that ticket that might give you some generic help info, but you would need to respond to it and say you’ve already tried resolving it in the ways you’ve described. This should escalate it to a human for resolution.

Thanks a lot for your support. I’ve sent them and Kajabi an email. Hoping this gets resolved soon.

Btw, if I pause Cloudflare does my website go back on? I still saw the error page when I paused it.

When I was testing it, it was a direct connection (unpaused) and broken. I did notice that the naked domain redirected to www, though. So that’s good, as you’ll need to use ‘www’ for Kajabi.

Okay… that’s good news I guess.

Why is it broken though? I thought my website would be live.

Good question.

Okay… I’ve contacted Kajabi’s support!

Thanks a lot!!

1 Like

Update:
Email I got from Kajabi Support
Hi Steven,

Thank you. We have performed all the troubleshooting steps that we know. However, it seems that it will not work unless the SSL becomes active. We even check the SSL of your domain. Kindly see the screenshot below.


In this case, it would be best to contact Cloudflare for further troubleshooting of your domains SSL.

This topic was automatically closed after 30 days. New replies are no longer allowed.