SSL doesn't works if started with www

Answer these questions to help the Community help you with Security questions.

What is the domain name?
www.sso.qreatiq.com
www.portal.qreatiq.com

but if I accessed without any www, it works fine. example
sso.qreatiq.com
portal.qreatiq.com

Have you searched for an answer?
Yes

Please share your search results URL:

https://community.cloudflare.com/t/naked-domain-https-doesnt-work-www-works/291626/13

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?
Both sso.qreatiq.com and portal.qreatiq.com only got errors on DNSSEC configuration and DS record.

But www.portal.qreatiq.com and www.sso.qreatiq.com got much error
Check for redirect loops, Check if redirecting unencrypted HTTP traffic works, Check the status of encrypted traffic, Check the site for mixed content, and Check site speed (TTFB) with the same error :
request_failed
Your request failed because the web server did not respond.

Describe the issue you are having:
If I’m trying to access sso.qreatiq.com and portal.qreatiq.com both of them work fine.
But if I’m trying to access with WWW then it doesn’t work.

What error message or number are you receiving?
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

What steps have you taken to resolve the issue?

  1. Add A record with www.portal.qreatiq.com and www.sso.qreatiq.com (still doesn’t work so i deleted it.)
  2. Trying to generate a certificate with host www.portal.qreatiq.com, portal.qreatiq.com, www.sso.qreatiq.com, sso.qreatiq.com, qreatiq.com, *.qreatiq.com
  3. Add page rule for redirection

Was the site working with SSL prior to adding it to Cloudflare?
Yes, for the main domain www.qreatiq.com and qreatiq.com works fine

What are the steps to reproduce the error:

  1. Access www.portal.qreatiq.com or www.sso.qreatiq.com

Have you tried from another browser and/or incognito mode?
Yes

Please attach a screenshot of the error:
image

1 Like

I recently added A record for www.sso.qreatiq.com also www.portal.qreatiq.com.
Thank you for your post. I hope my redirection page rule will work. Just waiting my propagation time.

Yeah, the records are fine, it’s just the SSL issue from the posted article. You need an ACM certificate.

Yes, thank you for the link. I need to go through ACM certificate to cover my scenario. By the way, why my page rule redirection doesn’t works? any idea?

Well, the site does not load, so it can’t redirect either. You need the ACM.

Im redirecting from https://www.portal.qreatiq.com to https://portal.qreatiq.com

If I access it directly to https://portal.qreatiq.com it loaded correctly both the site and SSL itself.

Again, you need the ACM.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.