SSL Doesn't work for FreshDesk

We have been trying to setup SLL for our support desk custom domain with FreshDesk. I have already mapped all the DNS records, and also created a Certificate. But the URL still does not support SSL.

What could be the issue here ?

Seems to me the support CNAME or A record is not being :orange: cloud (proxied via Cloudflare)?

;QUESTION
support.fyxoinc.com. IN A
;ANSWER
support.fyxoinc.com. 299 IN CNAME newaccount1611672835985.freshdesk.com.
newaccount1611672835985.freshdesk.com. 59 IN A 52.5.234.11
newaccount1611672835985.freshdesk.com. 59 IN A 54.88.140.129
newaccount1611672835985.freshdesk.com. 59 IN A 35.174.41.54

Returns SSL_ERROR_BAD_CERT_DOMAIN. Does it cover sub-domain?

If you are using a sub-domain and CNAME, do you have :orange: cloud or :grey: cloud for that DNS record at Cloudflare dashboard?

Moreover, what SSL option have you got selected under SSL tab/settings page at Cloudflare dashboard for your domain?

  • Full SSL, Flexible SSL …

Have you followed the steps from this tutorial?:

In case if needed, you can always alter SSL settings for just one subdomain using page rules.

@fritexvz - Thanks for the reply. I did follow the tutorial and currently the CNAME is using :grey: cloud (DNS Only) … and also I have created a certificate… See bellow screenshots

@fritexvz - Now I proxied it and cannot even go to the page. Getting following error

Under page rules

But does the Freshdesk interface have an SSL certificate installed for your sub-domain? (Not the Cloudflare Origin CA certificate one)

What happens if you select SSL Off or SSL Full?

Regarding redirect loops, kindly see the steps in the below article:

Invalid, expired or revoked certificates can be the cause