SSL doesn't cover mail. DNS subdomain?

I have setup DNS and SSL for my website. However, if I set the mail. DNS record to proxy, then email clients cannot access my account. If I turn off the proxy for the mail record, then I can get mail but get warnings about the certificate being self-signed from my server. I’ve seen in other threads that proxy is only HTTP related, but Cloudflare also only covers proxied records with the SSL certificate provided.

I’m on a cPanel account with Namecheap at the moment, so there is the shared hostname that can be used when setting up the email client, but that seems like it could throw flags for email deliverability. Any advice? Thanks in advance!

Welcome to the Cloudflare Community. :logodrop:

You need to ask your host how to install a valid certificate for your mailserver.

I have no idea why you think that, but it definitely should have no impact on email deliverability. Having working DMARC is far more relevant than the hostname used to connect to the SMTP relay.



I have previously been installing valid Let’s Encrypt certificates through my host that cover,, and The certificates auto renew for all of my domains/websites, but they do not auto-install. I was hoping Cloudflare’s free SSL option would be able to cover these same needs in order to avoid the hassle of installing each domain’s certificates every three months.

only works for proxied HTTPS traffic. It is not suitable for other protocols or direct connections.

It sounds like you may want to find a better host where Let’s Encrypt is not broken.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.