SSL cUrl Error 51


#1

Hello,

I am new to Cloudflare and I have come across a problem recently. I created a free SSL certificate via the admin panel and the website works well, but not the Wordpress administration. I can neither update nor install any plugins, I can’t preload cache as it just shows this error message:

"The following errors happened during gathering of the URLs to preload:

Preload encountered an error. Could not gather links on https://www.willflies.ovh because of the following error: cURL error 51: SSL: no alternative certificate subject name matches target host name ‘www.willflies.ovh’.

Sitemap preload encountered an error. Could not gather links on https://www.willflies.ovh/sitemap_index.xml because of the following error: cURL error 51: SSL: no alternative certificate subject name matches target host name ‘www.willflies.ovh’."

Could you guys help me please?

Thank you


#2

Hi @vnecesany, sorry about the trouble. That error references your origin server. SSL on the crypto tab is set to Full (Strict) and there is no cert on the origin, can you set it to Flexible?


#4

Hello @cloonan, thanks for your advice. I have done what you told me and now it seems to be working fine. Thank you very much :slight_smile:


#5

Keep in mind your site is not secure any longer and content is transmitted in plain text between Cloudflare and your server. If you do not want that you’d need to configure a proper certificate on your server and switch back to Full.


#6

Hi @sandro, I tried to go to Full SSL instead of that Strict and Flexible and it seems to be working so far. Thank you


#7

Full will also work as you do have a certificate, albeit an invalid one for your domain. The most secure solution would be aforementioned configuration of a proper certificate and “Full strict”. But Full is definitely better than Flexible.


#8

Ok so the problem was not fixed :confused: I got rid of the preload error message, can clear cache, install plugins, but can’t change anything. When trying to delete plugin or edit and save a page all I get is this short message: “Your safe has failed.” or “Deletion failed: 0”.
I don’t know what has been done wrong but the site was working well for about an hour and now it is not with either the Flexible or Full option set.
Any ideas, please?


#9

Can you post some screenshots?


#10


#11

Thats something very Wordpress specific and I assume you’d have the best success in finding an answer by posting in a Wordpress forum. These error messages are not very detailed, so I’d also try to dig through whatever logs there are.


#12

Ok, I’ll try to post it on a Wordpress forum.

Thanks for you help anyway, appreciate it!


#13

Well, this is kinda weird IMO :confused: Googled that it may be the browser causing this issue, so I tried to perform the same steps in Avast browser instead of my default Google Chrome and here is the result:

It was all about clearing cookies, history and all files from Chrome. So I will try to get back to the Full (strict) SSL now.

Thank you all for help :slight_smile:


#14

Full strict probably wont work, unless you have installed a proper certificate meanwhile. Simple Full should though.