SSL correctly installed but still no https

Hello fellow Cloudflarers.

I’m running into issues trying to set up my SSL certificate. My hosting is infinityfree and i’ve changed the nameservers on my registrar to point to cloudfront. When i run a SSL checker on my domain it says that it’s correctly installed, yet i can’t enter the site through https, only http works.

My domain is: hilma.studio

I’ve configured the security settings correctly (i think) on cloudflare. When i log in to cloudfront i’m presented with the message " Great news! Cloudflare is now protecting your site".

My DNS configuration is this:

----------CNAME 1-------------
name: hilma.studio
content: pepedxvb.epizy.com (this is my main domain in infinityfree)

--------CNAME 2---------------
name: www
content: hilma.studio

Both of these are proxied through CF according to the UI.

A strange thing i noticed is that for a brief period i had the padlock and https seemed to be working, but when i uploaded a new version of the website it disappeared again. Right now i just have a placeholder index.html on there.

I set this up yesterday so i’m guessing there might be something wrong with my configuration although it says it’s correctly installed when i check the SSL with https://www.digicert.com/help/

This is super frustrating and i don’t know what to do. Please help :frowning:

Hi, I just tried navigating to your site hilma.studio, and I was presented with the place holder page, and ssl was working. Maybe something in your browser cache is preventing the SSL from working. Try clearing your cache or loading the site in a private tab to see if it loads with SSL.

Thanks for your reply.

My bad, yeah it seems to have been cached. It’s working now but earlier today I was testing in both incognito and in a normal tab and couldnt get access to the https at all. I feel really stupid now.

1 Like

Don’t worry, we’ve all been there! Glad things are working for you now.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.