SSL Configuration

Hi,

My sites were hosted on hostinger with the SSL which was purchased by cloudfare. Now I have moved my site hosting the AWS Lightsail so need support to complete the SSL certificate.

#CommunityTip 521

Lightsail lets you generate and attach SSL/TLS certificates to your domain:

https://lightsail.aws.amazon.com/ls/docs/en_us/articles/understanding-tls-ssl-certificates-in-lightsail-https

Hi,

I already have SSL from cloudflare for my site which is installed as well. Now when I open the site in the begining its shows the link is SSL certified however once the site opens its start showing non SSL site.

Not sure how to fix this issue.

Regards,

Fawad

What’s the domain?

Have you enabled force HTTPS in cloudflare’s SSL control panel?

Hi,

The domain is news1602.com and yes its enabled forec HTTPS in cloudflare.

This does not seem to be the case. In the SSL/TLS section for Edge Certificates. Make sure "Always Use HTTPS is enabled.

With HTTPS, your site is showing Mixed Content.

I tested and found that you did not set to enable https forcibly. It is normal to access https connection directly.

I have enabled it but still getting the same issue. Please check and advise.

It doesn’t respond like it’s enabled.

Please post a screenshot of your SSL/TLS -> Edge Certificates screen. Please be sure to include the “Always Use HTTPS” section.

As requested.

Ah, that’s it. It’s a little confusing. While it looks like it’s saying “Click to turn Off”, the “Off” means it’s off. Click on it and it will turn green and say On.

Thanks for your response.

I have changed the button as you has requested.

Normally how long will it take to effect?

Normally, just a few seconds for settings to take place across Cloudflares global network.

Its been an hour now but still the issue is same after changing the configuration. Please advise.

I opened it to see it is normal, but there is a non-https connection in your website content, the browser will prompt insecure, you can open [Automatic HTTPS Rewrites] option.

That sounds like Mixed Content.

that option was already on so I feel this issue is something else. Please bear in mind that I am using multisite wordpress instance.

There are five style codes that refer to http resources in the page code. Please modify it to a relative address or https connection.

1 Like

Can you please advise how can I modify it? I am using multisite wordpress instance.