SSL configuration error


I configured Cloudflare DNS for my website, but we I enable the proxy functionalities I not enrich anymore my website.

My DNS works well, i have the following configurations:
domain a
pluto a
paperino.pluto cname pluto

If i leave paperino.pluto without proxy works, if I enable the proxy function not work anymore.

on the service behind paperino.pluto.pippo.inf I have a let’s encrypt certificate and the browser trust it without any issues.

I tried all type of ssl configurations on Cloudflare dashboard but without any result (strinct, flex and disable) force and not force ssl and so on, sometimes I received this error ERR_SSL_VERSION_OR_CIPHER_MISMATCH.
In the perimeter certificate I want to use the universal certificate without buy never because the services behind not justify this.

my goal is to mask my real ip and some protection from scanning…

someone can help me pls?

many thanks


Thank you for asking.


Unfortunately, Cloudflare’s Universal SSL cover and * . This means that it covers any subdomain one level below the domain you signed up with.

It will cover and , as these are one level below the root domain, .

The certificate will not cover or , however, as these subdomains are too deep → which is your case paperino.pluto.pippo.inf.

In this case, you should use Advanced Certificate Manager:

More about this can be read at the link below:

thanks for the answer, but in theory if i remove the ssl part (set to disable the ssl) need to work without a certificate on Cloudflare part right? if yes I don’t understand why doesn’t work.

in order to verify the configuration a create a temporary name (if I understood right, this can work with universal certificate) but same result, same ssl error

can you please suggest the right configurations?

many thanks

someone can help me?