SSL Certificate with Subdomain

ssl

#1

I’ve rented a domain with namecheap and my concern is that the subdomain does not get SSL certified. Is there a way to do this or is it more of a premium plan settings that customers have to upgrade to?

As well as my main domain does not get automatically redirected to a SSL certified site even after setting up in crypto with the Always use HTTPs to be [On]. Can someone help me out here or knowledgeable enough to know if this is only doable in premium plan accounts?

Main Domain: skyvaults.net
Subdomain: store.skyvaults.net


#2

You have not changed your nameservers to point to Cloudflare. Until that happens Cloudflare won’t be able to request an SSL certificate nor is your traffic routing through Cloudflare.


#3

can you provide an example of how i would do this? Is there a way to create a record that would change nameservers pointing Cloudflare?


#4

Currently using Namecheap if that helps.


#5

Name servers are set from the “Domain” tab on the picture you posted.
https://www.namecheap.com/support/knowledgebase/article.aspx/767/10/how-can-i-change-the-nameservers-for-my-domain

Your Cloudflare name servers are listed in your DNS settings page here at Cloudflare. Scroll down a bit until you get to the NS section.


#6

If i use custom nameservers wouldn’t the advanced DNS connections disconnect all together?
image


#7

Everything listed in the Advanced DNS section should have transferred over to Cloudflare. If not, take a note of all those A/CNAME/SRV/TXT/MX records so you can update your DNS here at Cloudflare.


#8

i have directed my domain to Cloudflare.


#9

Ok, give it a few hours (maybe a day) for the name server change to propagate.


#10

It looks like it’s mostly propagated.
https://www.whatsmydns.net/#NS/skyvaults.net


#11

As far as for store.skyvaults.net this is what it’s showing. it is a subdomain
Could this be an issue from the website provider’s end?


#12

You probably have SSL set for Full here, but ‘store’ doesn’t have an SSL certificate.
You could 1) Put an SSL certificate on ‘store’ or add a Page Rule here that matches store.skyvaults.net/* and add a Setting for SSL to be set to Flexible.

But it really needs to have a working SSL certificate.


#13

and that would be provided for free as well?
would this work?


#14

Whatever you did to skyvaults should also be done to store. So, if your server has an SSL for skyvaults, see if there’s a way to do it for store as well. Then you can use the same SSL Full setting for both.

But for now, yes, that Page Rule should help if store does not have an SSL certificate.


#15

Somehow it worked and it’s now also SSL certified. Hmm…
https://store.skyvaults.net/


#16

This topic was automatically closed after 14 days. New replies are no longer allowed.