SSL Certificate Stopped Working

I had configured SSL for my wordpress site (amathur.org) 3 days back, was working fine then.
Logged in today, SSL was gone, its back to unsecured.

Very similar to SSL certificate worked for a few minutes and stopped working

Please help.

Thanks
Asheesh

On the ssl/tls app, edge certificate tab, can turn on always use https? Loads fine for me. If still having issues, clear cache and/or try different browser.

Thanks for suggestion, https is now working, if I explicitly specify https.
Otherwise http is also working showing Not Secured.
Looks there’s an issue with redirection.

Did you enable “Always Use HTTPS” in the Edge Certificates section?

I use chrome browser, installed plugin. It’s working now.
However for other users, how can I enforce this. Planning to remove this service

^ This way ↓

1 Like

Yes, you are right. I got the same problem. The SSL on my primary website shiningjobs.com is working fine, but when I tried to other sites, it could not work properly. so I removed the other site.