SSL Certificate Renewal confirmation link doesn't work

I received an email from Cloudflare stating I needed to add a CNAME record in order to renew my Cloudflare SSL certificate. I added the CNAME and when I try to click on the link to complete the renewal process (in the Cloudflare email), the link does not work. How else can I complete the process

2 Likes

Does it show an error, or does it just not confirm? You may try setting that CNAME to :grey: DNS Only if it’s not already that way. Clicking on the :orange: will toggle it.

The link in the Cloudflare email doesn’t do anything when I click on it. It should open up a web page and confirm my certificate renewal, but it doesn’t do anything. It seems to be an issue with the email Cloudflare sent me but they will not respond to my support request because I have a free account. So I’m stuck…

Well I was finally able to copy the link into a text document and then paste into Chrome and the page opened. However, when I click the Approve Certificate link it throws the following error message:

An error occurred while attempting to validate your domain. Please try again later or contact support for assistance.

I will try again later.

Thanks for trying to help.

OK I have tried multiple times since last week and every time I click the Approve Certificate link I get an error message. I’ve tried contacting support and they keep sending me back here. Can anyone please help me figure out why it won’t validate? Thanks in advance.

1 Like
  1. Please post the ticket # here.
  2. Keep replying to the same ticket. Eventually it might annoy them enough that they’ll have someone look at it.

@MoreHelp
Regarding [Cloudflare Support] 2222155 - Cannot verify certificate

I have posted on this community and no one has been able to help me resolve this issue.
I have submitted 2x to Cloudflare Support, only to be told to post in the community.
I need to have this issue resolved ASAP or TOMORROW AUGUST 5th per your email you will cancel my SSL

I have followed ALL of the instructions in your email for a week now and am still unable to renew my certificate.
Please help. I do not want my certificate to expire!

@1blas might still be around. Maybe he can whip this into shape. I’ll escalate it with the ticket number.

thank you I appreciate any and all help!

I apologize for the issues @dlachusa. I see your ticket with Support and have added myself to it to track, added a link to this discussion, and reopened the ticket. I also see this topic has been escalated for my colleagues.

I am curious, when you click on the link to activate the certificate do you have any ad blocker software running?

2 Likes

no ad blocker that i’m aware of. I do not get a message notifying me of one

1 Like

With some effort, I typed in the CNAME you were supposed to enter, and it’s not resolving. Can you:

  1. Paste that CNAME value they asked for into a reply here in case I mistyped it?
  2. Post a screenshot of that CNAME entry on your DNS page?
  3. Confirm that the two name servers at the bottom of your DNS page here are Jamie and Lou.
1 Like

Please add the following CNAME entry to your authoritative DNS provider:

_ca3-5d6846c0e942477984a0685ec213ccda.debbielachusa.com CNAME dcv.digicert.com

My website is hosted at Siteground, so I had to add the CNAME record there. So I’m not sure your #3 applies, or if so, how to check it (Jamie & Lou)

FYI Siteground Support helped me add the record and they said it is set up correctly…

1 Like

Cloudflare is your authoritative DNS provider. That’s why I asked about Jamie and Lou. You need to add that CNAME record here at dash.cloudflare.com

Oh, you are on a Partner partial setup. Then yeah, it was always a thing to do at Siteground.

I don’t think so. Her domain is using Cloudflare name servers. Which would explain why adding the DNS record at Siteground isn’t working.

Ehm, no.

dig ns debbielachusa.com +short
ns2.giow1015.siteground.us.
ns1.giow1015.siteground.us.
dig www.debbielachusa.com +short
www.debbielachusa.com.cdn.cloudflare.net.
172.67.186.188
104.21.43.228

Same goes for whois, but it’s harder to format well.

Darn it. You’re right. My WHOIS lookup returned two sets of name servers.

Then she’s going to have to bug Siteground about this. That CNAME still doesn’t resolve.

1 Like

I don’t think it should. It’s just there for the random ID part for validation.