SSL Certificate Not working!


#1

So I have installed cloudflare and everything in the overview is active as well as in the crypto tab it is green and set to active, but when I go on website no padlock… I have cleared the browser multiple times but when I clear the browser and go to my site it says ERR_SSL_VERSION_OR_CIPHER_MISMATCH & maybe after clearing my browser a couple times and some minutes pass by it disappears and lets me go to my website with no ssl, but everything is still active. Please help me out Thank you!


#2

Whats the URL?


#3

Whats the status of your SSL certificate in your Dashboard? It should be “activie”
If you recently activated SSL just wait a bit. It usually should be issued within 15 minutes but can take a bit longer sometimes.

EDIT
forget my question :joy:


#5

DNS seems to work, TLS does still have an issue. I guess you should still wait a bit.


#6

Your server shows a Let’s Encrypt Certificate

* SSL connection using ECDHE-RSA-AES128-GCM-SHA256
* Server certificate:
* 	 subject: CN=www.alfredodesign.com
* 	 start date: 2018-04-29 14:01:23 GMT
* 	 expire date: 2018-07-28 14:01:23 GMT
* 	 subjectAltName: www.alfredodesign.com matched
* 	 issuer: C=US; O=Let's Encrypt; CN=Let's Encrypt Authority X3
* 	 SSL certificate verify ok.
> GET / HTTP/1.1

And it seems it is not behind cloudflare, showing an AWS IP.
But since it is a WIX setup i am not pretty sure …


#7

www.alfredoesdesign.com


#8

WTH? i used C&P o_O

I’ll go back to bed… :frowning:


#9

:thinking:

Depending on where you are, that could be an excellent idea :wink:


#10

C&P = Copy and Paste

Germany :slight_smile:


#11

I got that, I was just surprised as well what was going on in that case. Only explanation I could have is that the OP maybe posted the es-less domain, you copied it, he noticed the typo and fixed it.

Otherwise, mystery :slight_smile:

Well, in that case depending on when you came back home / went to bed originally :wink:


#12

So if not fixed by tomorrow. What should I do?


#13

I’d expect it to work in the next couple of hours. If it is still not working in 12 hours I’d open a ticket with Cloudflare’s support.


#16

I have tried moving the files to my main root public folder and still getting 404 error. Any other idea what this could be.


#17

This looks like a local issue on your server though, not something Cloudflare related. The aforementioned TLS issue does seem to be fixed now.


#18

I have fixed the problem. My A MX Entry was set to parked to a set IP address changed it to the right IP address and it works. Thank you for the help!


#19

we have been waiting for more then 24hours for the ssl status to be Authorised

please can some one advise

thank you

adnan


#20

I wouldnt mix your issue with the one at hand. Either open a new thread or contact support.


#21

okay.


#22

So everything is fine now?


#23

This topic was automatically closed after 14 days. New replies are no longer allowed.