SSL Certificate not working on Wordpress

Hi everyone this is my first post.

I installed an SSL certificate to my Website around 12 hours ago and it is not working, even though the site is listed as “ACTIVE” on my account.

Any suggestions to resolve this problem would be appreciated.

My Website is a Wordpress/Elementor site.

Thank you.

Steve

How did you install the SSL certificate on Wordpress, have you set up Cloudflare for SSL as well? If you could link your domain here as well so we can take a more in-depth look at the SSL certificate that is linked(or not linked if it isn’t)

Please dont forget to also change your perma Links from “HTTP://domain.tld” to “HTTPS://domain.tld”.

In total you have to do these things.

  1. set CloudFlare to SSL Flexible
  2. install SSL on Server
  3. change permalinks (as shown above)
  4. set CloudFlare to SSL Full (Strict)
  5. activate the automatic rewrite in CloudFlare and all other desired SSL options.

Have fun

I deleted the nameservers from Go Daddy who was my original host and replaced with the nameserver details given by Cloudflare.

When I check on my account it says " Account Active"

This topic was automatically closed after 30 days. New replies are no longer allowed.