SSL certificate not working on second subdomain

Greetings dear community,

I’ve been using Cloudflare for a while now, and everything was going pretty smoothly. I had a SSL certificate working on my wordpress website on https://sub1.domain.com.
However, I recently (>24h) created a second subdomain, but I can’t get SSL to work on https://sub2.domain.com.

I’m using Flexible SSL, I have a universal Cloudflare certificates which covers *.domain.com and domain.com. Both subdomains have the same DNS configuration in Cloudflare (orange clouds everywhyere), so I really can’t figure out where this problem is coming from. I checked the numerous posts related to that subject but couldn’t solve the problem.

Any idea would be greatly appreciated!
Many thanks for your help.

What are you seeing that makes it look like that subdomain isn’t working? If you share the subdomain name, we can take a closer look.

Hello sdayman,

Impressive response time! The working subdomain is https://sub1.domain.com, while I’m getting a SSL_ERROR_NO_CYPHER_OVERLAP on https://sub2.domain.com.

However, it seems I may have a redirection from https://sub2.domain.com to https://www.sub2.domain.com, although both subdomains have the same configuration.

That’s actually a sub-subdomain (second level subdomain). Cloudflare’s SSL certificates don’t cover that deep of a subdomain. They only cover example.com and sub.example.com. If you want to go down to www.sub.example.com, you will need the $10/month Dedicated SSL Certificate With Custom Hostnames, then add that (and any other) second level subdomain to the certificate.

1 Like

www.sub.domain.com would indeed be a sub-subdomain. However, sub1.domain.com and sub2.domain.com should both be regular subdomains, thus I don’t understand why https://sub1.domain.com would work but not https://sub2.domain.com.
Any hint?

butineurdexperiences does work, but it redirects to www.butineurdexperiences, which does not work.

2 Likes

Hi again. Once again, many thanks for your help. Would you know what might be causing this redirection? I’ve tried setting a rule in my .htaccess to redirect www to non-www, though it only created a redirection loop. I’ve checked all possible options from my provider and couldn’t solve it.
Checking my Cloudflare configuration, both subdomains have exactly the same configuration, so I’m running out of options. My current configuration is as follows:
A / domain.com / IP
A / sub2 / IP
A / sub1 / IP
A / www.sub2 / IP
A / www.sub1 / IP
CNAME / www / alias of domain.com

I’ve been checking possible ways to find out where this 301 comes from, though I still can’t figure it (e.g. https://www.quora.com/Whats-the-best-way-to-reverse-a-301-redirect)
Many thanks for your time.

Solved by recreating the website from scratch!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.