SSL Certificate not taking effect on my domain

crypto
#1

So I created my Cloudflare account, set up my domain, changed my domain DNS, followed all the instructions and got my flexible SSL cert.

It displays as -Universal SSL Status Active Certificate **

But it’s not taking effect on my domain. It’s been about 10 hours. Now, obviously if the status was still authorizing, I would have waited to post here, but I’ve never had an SSL cert take longer than 30 minutes to take effect after it’s listed as ACTIVE. Is there a reason for this?

I can’t seem to find a solution.

Thanks.

#2

What’s the domain?

#3

http://auburneyephysicians.com

Thanks for any help.

#4

https://auburneyephysicians.com/ certificate is valid however, you have some mixed content you’ll want to address and here is a Cloudflare tutorial to Fixing Mixed Content Errors

2 Likes
#5

Yes, I’ve already tried fixing it. I’ve force changed everything, I’ve tried re-directing all URLs to https:// but the problem is, once I do that, I still get the error. For instance.

http://auburneyephysicians.com/wp-content/uploads/2018/04/x1158175-auburn-eye-physicians.jpg.pagespeed.ic.6mKF6NSXS4.jpg - works.

but
https://auburneyephysicians.com/wp-content/uploads/2018/04/x1158175-auburn-eye-physicians.jpg.pagespeed.ic.6mKF6NSXS4.jpg - does not work.

If it were a problem with just mixed media, I wouldn’t be getting an unsecure error with that image, right? So I reverted everything back until I can figure out what’s going on.

I totally get what you’re saying, I just don’t know how to fix it based on the solution offered.

#6

Both of those examples worked for me too. You’ll probably want to use Development mode in the Cloudflare Dashboard and disable browser caching on your end while testing.

#7
  • You could also go in to the WP database and search http:// as mentioned in the Community tip or use the SSL content fixer plugin.
#8

I’m just so confused. I’ve flushed my DNS. I’ve used a different browser and I can see that the cert is there on my phone (still with errors of course), but for Chrome, it’s showing no certificate.

Tried development mode. Tried disabling browser cache temporarily.

No dice. Any other suggestions?

Does it have anything to do with my wp-config file not being writable? I mean, I can edit it myself and change my domain to https:// but plugins can’t edit the wp-config file. Is that a problem?

#9

Also, I used SSL fixer. Didn’t work.

#10

Now that the certificate is working, this shouldn’t take long and should start everything from the beginning. This time in Development mode, disabling your browser cache and/or caching plugins and purge the Cloudflare cache. Then run an SSL plugin and/or manually configure or review the MySQL entries and config files in that order.

#11

Just tried all of that.

No dice.

#12

Try going in to your WP Dashboard > Media then manually confirm images and other media in “File URL’s” (top right column) have been rewritten to https by the plugin. If not, then they haven’t been modified for some reason.

#13

Unfortunately I am not able to manually edit those or even manually change my domain name to be https://.

#14

With Flexible SSL, you won’t be able to change Wordpress’s settings to https.

But you can add the following to .htaccess to fix mixed content:

Header always set Content-Security-Policy: upgrade-insecure-requests

2 Likes
closed #15

This topic was automatically closed after 30 days. New replies are no longer allowed.