SSL Certificate issues with OVH hosted site

I am unable to get the SSL certificates for my domain to register/work.
Domain nathanwbrammer.com is currently registered on Cloudflare and wordpress site hosted on OVH. I have ensured the A, AAAA, TXT name servers are directed as required as per the instructions from OVH.

I have tried to walk through all the help files I can find, but the all basically say it should do this or look like that for each step. Except mine doesn’t and there’s no -if it doesn’t look like this or say that - you need to check XYZ.

I assume there is a setting or file that needs to be correct or updated but I can’t find what.

There is a redirect, my guess from wordpress, that is going to http://oznucfr.cluster051.hosting.ovh.net/. If you remove that redirect, then it should load from your site.

Your site won’t be properly configured for that domain, hence it sends you to the default hostname.

You need to configure your server properly for your domain and also deploy a valid SSL certificate on your server and you need to fix your encryption mode on Cloudflare as you currently have an insecure one.

Best to pause Cloudflare until the site loads fine - Pause Cloudflare · Cloudflare Fundamentals docs

Thanks mate, that fixed it up. Knew it was going to be something simple that I had just missed.

Not entirely sure here

Hadn’t tested in Firefox, was just missing the http’s’ in the Wordpress URL so was conflicting. Should be all good now :slight_smile:

It’s not Firefox related and HTTPS was not missing. You need to fix the server certificate and the legacy encryption mode on Cloudflare.

It’s still the same message and your site has no encryption.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.